2

I'm using autofs mounting of a samba share from a Windows 10 (Creators edition).

Microsoft patched its OS to no longer accept smb version 1.0 sometimes in 2017.

SomeFolder -fstype=cifs,rw,username=johndoe,password=********,uid=root,file_mode=0777,dir_mode=0777,noperm,noserverino,iocharset=utf8,sec=ntlm://servername/SomeShare

See Mount CIFS Host is down for more information on the problem and solution.

After a while it finishes negociating (half an hour?) and then keeps working fine.

How do I do -o vers=2.0 with autofs?

1

The option vers is ignored in, at least, Debian 8 (jessie). We had issues mounting smbv2 shares, even with smbv1 disabled on the server side and -o vers=2.0 set. I tested it on a Debian 9 (stretch) box and it worked. But you have to use the vers option. Otherwise smbv1 is tried and you can't mount the share.

3

For example, you can use something like this:

-fstype=cifs,file_mode=0770,dir_mode=0770,nounix,uid=1000,gid=1000,vers=2.0
  • Could you expand the answer a bit to explain what it does and why the difference between this and the original is important? – Seth May 26 '17 at 8:57
  • I think vers=2.0 is being ignored. Actually, disabling SMB 1.0 in the Windows registry resulted in inability to connect at all. I'll do some more tests soon. – Tiberiu-Ionuț Stan Jun 1 '17 at 19:05
  • 1
    worked for me (with vers=3.0) on raspbian Jessie with automount 5.0.8 – foraidt Aug 12 '17 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.