-1

I have successfully run Ubuntu on my computer with an older version of VBox in Windows 7.

I updated VBox, and downloaded and imported a Kali Linux 2017 i686 .ovf file. But then I got an error after which I installed the extension pack. Now I'm getting a different VT-x error.

If it helps, the Acceleration reads : PAE/NX, KVM paravirtualization. The acceleration tab in settings is disabled.

Failed to open a session for the virtual machine Kali-Linux-2017.1-vbox-i686.

VT-x is not available (VERR_VMX_NO_VMX).

Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

  • What error? Paste the exact error message here. – Larssend May 25 '17 at 9:07
  • 2
    Do you use Hyper-V in Windows too? druss.co/2015/06/… suggests it might be a cause of the error... – Kinnectus May 25 '17 at 13:37
  • @BigChris Will enabling Hyper-V and/or Virtualization affect my computer in any other way? No negatives right? – ProgramSpree May 25 '17 at 14:01
  • Hyper-V is Microsoft's virtual machine technology but it's a built-in feature that needs to be enabled and would need your VT-x enabling in BIOS etc. before you could use it properly. The reason I ask is that an online resource seems to suggest it may cause the error you're experiencing - along with whether you've actually enabled VT-x in your BIOS :) – Kinnectus May 25 '17 at 14:07
  • I downloaded Speccy and found out that my system does not support virtualization. Thanks for all your help, though! – ProgramSpree May 28 '17 at 3:15
0

I would follow: https://stackoverflow.com/questions/5482223/vt-x-is-not-available-when-i-start-my-virtual-machine

That error is more pointing to that your computers bios doesn't have virtualization enabled. That option isn't available on all CPU's.

Take a look into bios and verify that virtualization is enabled, if you can't find the option, verify that your CPU has the ability.

Most follow a VT- enable/disabled option, generally under CPU settings in bios.

  • But the OP states at the start he could run Ubuntu before he upgraded VBox... might have been prudent to ask if the user has enabled VT-x rather than assuming it's off... – Kinnectus May 25 '17 at 13:54
  • 1
    @BigChris He did say that, but most of the time it's disabled. Maybe a firmware or update he did installed disabled it. The only other option I see is that he has Hyper V enabled, and according to druss.co/2015/06/… can cause same warning. – JustAGrump May 25 '17 at 14:00
  • Lol which I've already asked the OP under the question :) – Kinnectus May 25 '17 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.