1

Using a DLink DSL 2750U ADSL router with v.ME_1.15 firmware. Trying to change the DNS provided by ISP to Google DNS. I change the DNS in router configuration page, click on'apply', immediately reboot the router. But after router reboots, the DNS reverts to ISP DNS by itself. 'Obtain DNS server address automatically' is unchecked and 'Use the following DNS server addresses' is selected. Did a hard reset of the router and configured it again, still no good.

I purchased the router myself, not bundled with any ISP contract, if that matters somehow. How do I 'force' the router to use Google DNS instead of the ISP DNS.

  • Open a ticket with dlink - it is a bug by the sound of it. – Paul May 25 '17 at 4:37
  • Thanks. I manged to flash firmware version IN_1.06 and it saves the DNS now. – Atul Jun 16 '17 at 11:44
  • Could you add this as an answer and accept it? – Paul Jun 17 '17 at 23:20
0

The problem was solved after I flashed it with Firmware IN_1.06. Firmware v.ME_1.15 which I had flashed earlier (just after purchase) is supposed to be for Middle East variant of the router while IN is for the ones marketed and distributed in India. Flashing with ME_1.15 earlier had not bricked my router (that's just my personal experience, I don't know if that is how it should or is supposed to work) but it did cause the problem with DNS server that I posted.

Also, the link for IN_1.06 firmware on the official product support page is dead but a support rep emailed to me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.