11

Note: I will be answering this question myself to help other people who come across this problem in the future. Feel free to submit your own answers if you want, I know that other people have had this same problem, but caused by a different issue than the one I had.

I have just installed Windows 10 on a new computer, and when I move or unpin tiles in the Start Menu, they are reset to their original location after rebooting the computer. If I attempt to pin a new tile to the Start Menu, Windows Explorer crashes. How can I fix this problem?

  • Did you try to make it permanent with group policy and XML file? – Biswapriyo Oct 12 '17 at 5:13
  • @Biswa I tried many group policy changes, but I didn’t try making a permanent static XML-based layout since my goal was just to get the start menu functioning how it normally does on a clean install. – Steve Oct 19 '17 at 13:34
  • Finally found a solution that works for me now 24 hours. Credits for Diassembler0 here! Run the following PowerShell command: Remove-ItemProperty -Path "HKCU:\Software\Microsoft\Windows\CurrentVersion\BackgroundAccessApplications" -Name "GlobalUserDisabled" -ErrorAction SilentlyContinue Get-ChildItem -Path "HKCU:\Software\Microsoft\Windows\CurrentVersion\BackgroundAccessApplications" | ForEach-Object { Remove-ItemProperty -Path $_.PsPath -Name "Disabled" -ErrorAction SilentlyContinue Remove-ItemProperty -Path $_.PsPath -Name "DisabledByUser" -ErrorAction SilentlyContinue } – Ralph Jansen Jan 22 at 7:11
17

If you are running Windows 10 Pro, the first thing to check is that the Start Layout group policy setting is not set under Administrative Templates\Start Menu and Taskbar. This setting is under both User Configuration and Computer Configuration.

The actual problem for me was caused by changing the timezone. Since this was a new install of Windows, and now since the Creators Update Windows does not ask you for the timezone during the install, I had to manually set the proper timezone in the Settings app. In my case, I set the timezone from UTC-8 to UTC-5, so back 3 hours. Due to a possible caching problem with the Windows 10 Start Menu, any changes I made to the Start Menu would not be saved. Whenever explorer.exe was restarted (from a Windows reboot or through the Task Manager), any changes would be reset.

The solution was simply to wait 3 hours for the time to catch back up to the original time before the timezone change. I verified this by changing the timezone from UTC-8 to UTC-5, verifying that it broke the Start Menu, waiting 2.5 hours, checking that the Start Menu was still broken, waiting another hour (now 3.5 hours), and verifying that the Start Menu was now fixed. I did not do anything else to the computer during this time.

Therefore if your Start Menu is not updating and you recently changed the timezone, just wait for a few hours and it will fix itself.

Edit: As this seems to be fairly popular, it would be nice if someone forwarded this bug to a Microsoft employee :)

  • The same thing was happening to me. I've just installed Windows 10 Creators (Build 15063, version 1703) and I wasn't asked for the timezone (it was set automatically by internet as -03:00). The start menu couldn't be customized, because they were always changed by default tiles, until I wait. In my case, I tried again after 10 hours, when I back from work, and everything works fine. – Marcelo Barros Sep 7 '17 at 0:33
  • But what's the relation between time zone setting and start layout? – Biswapriyo Oct 12 '17 at 5:11
  • @Biswa I could only guess, like it may be caching something and storing only the date/time and not the timezone, but I don’t know. It’s almost certainly a timezone issue though, since the problem only occurs after changing the timezone to one where the local time is earlier, and the delay until the problem is fixed is predictable by the timezone difference. – Steve Oct 19 '17 at 13:29
  • 2
    @ghiscoding I’m glad this could help someone, it’s a very weird bug and it took me about two days to figure out. – Steve Nov 29 '17 at 4:38
  • 1
    @Steve I cannot believe that this was the solution. I changed my timezone because apparently Windows can't even set that correctly, and then was faced with this issue. I never would have thought this to be the cause and I'm glad I found your post, I waited until the next morning and all is well! – swerly Dec 13 '17 at 18:41
5

Deleting key

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\CloudStore\Store\Cache\DefaultAccount

helped me out

Ive found more info in english here : https://news.softpedia.com/news/how-to-reset-windows-10-fall-creators-update-start-menu-and-clear-all-tiles-519699.shtml

Basically its a tree thats responsible for live tile caching. Deleting this key will reset live tile cache and fix problem with different timezones.

  • 1
    Could you explain where you found this suggested as a solution and why it should work. Otherwise it just sounds like a completely random registry change which has nothing to do with the problem. – robinCTS Aug 7 '18 at 15:09
  • 1
    I was checking various forums where people had the same issue. Added more information regarding my answer. – Scr34mik Aug 7 '18 at 17:53
  • i did this on win10 and it broke my start menu button. ='( – w-- Sep 6 '18 at 11:24
  • This should work. I had the problem and used this solution. Another on SU: superuser.com/a/1252166/86687 – DatVM Dec 12 '18 at 8:25

protected by Community Jan 26 '18 at 13:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.