2

enter image description here

  • Above is my port forwarding configuration for TCP/UDP. OS is Win10
  • Online open port checking tools show the ip:port address as 'connection refused'.
  • Only one router being used, ethernet connection.
  • Verified that the right internal IP address is used.
  • Windows firewall is disabled, and no firewall that I'm aware of is on this router.
  • Tried enabling DMZ and setting it to the internal IP of the server.
  • Tried using different ports.
  • Haven't seen anything in the similar questions which might help.

I can't seem to figure this one out. I'm quite positive I've followed forwarding instructions to the letter, but...apparently not. Where am I going wrong?

5
  • Your ISP is likely using Carrier Grade NAT. Please read Alternatives to Port Forwarding & NAT: "There are four major problems that you may run into that would require alternatives to port forwarding. " ... – DavidPostill May 26 '17 at 16:58
  • Check that your external IP is what you think it is. Ask Google "what is my IP" to be sure. I watched someone struggle with this once, not realizing that their IP was frequently changing with modem/router reboots during setup and attempted testing. – Tyson May 26 '17 at 18:37
  • Also you should go look up your ISP on DSLreports.com, you'll be able to figure out quickly if carrier grade NATs in use or if they restrict, you'll be able to get a clear idea of what's allowed/disallowed. (DSLreports has listings for all types of carriers whether DSL, cable, mobile, etc... The sites name tells more about the era the site was originally created than it describres the current content.) – Tyson May 26 '17 at 19:59
  • Have you verified that your machine at IP address 192.168.1.3 is up and awake and is running some process that's listening on port 64738 on its 192.168.1.3 IP address? That is, can you connect to your server machine's special service by private IP address from another machine on the LAN? Is whatever server software you're running set to accept connections from remote (not on the local subnet) IP addresses? – Spiff May 27 '17 at 0:45
  • DSLReports shows no information on my ISP. The machine at that internal IP is the one I'm currently on, and the process is running. External IP verified correct. There is a possibility that my ISP might be blocking UDP ports, but I have not been able to verify this. Tried checking by running Wireshark and having a friend send packets to my UDP ports, but nothing came through. Same for TCP though, so perhaps I did not set Wireshark up correctly. – Hiigaran May 27 '17 at 1:59
1

There are a number of possible issues here. Its impossible to tell what the issue is without more information.

These possibilities include -

  1. Your router is, itself, behind NAT (possibly carrier grade NAT) in which case your upstream providers would need to also set up port forwarding for things to work.

  2. You are not running a service on port 64738 on your device. If you are not running a service it will not respond. There are no well established services associated with port 64738.

  3. Your computer does not have a default gateway set - although this is unlikely because if that were true you would not have any Internet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.