1

My computer was running super fine up and until recently when it started giving me random BSOD errors. I am running windows 10 home 64bit with NO overclocking.

I have updated all the drivers to latest version and there are no virus or malware in my machine. I ran the "sfc /scannow" command in CP and it tells me that everything is fine and dandy.

I received some BSOD in the past, not frequent, due to the Wdiwifi.sys. [Bad Pool memory] on my other system. I went to device manager and checked for updates and everything is up-to-date. 

The other two ndis.sys BSOD [kernel security check failure] error was caused when I was using blender. It was random.

https://drive.google.com/file/d/0B0z47lWdEdGPZlVtY1lmTGh4Wms/view?usp=sharing

enter image description here

  • 1
    share the dmp files so that we can try to debug them. Blurscreenview is crap – magicandre1981 May 27 '17 at 8:36
  • @magicandre1981 how do I share the file? you can grab the file from here tenforums.com/bsod-crashes-debugging/… – 4-K May 27 '17 at 8:40
  • 1
    MS hasn't uploaded the PDBs for latest update rollup. I need to check this in a few days. – magicandre1981 May 27 '17 at 15:21
  • 1
    the PDBs are now online and I posted what I saw from the dump – magicandre1981 Jun 7 '17 at 15:11
  • 1
    have you tried other Realtek Wifi drivers? – magicandre1981 Jun 10 '17 at 9:41
1

The debug symbols are now online.

Analyzing the dumps with Windbg shows that the Realtek Wifi driver (rtwlanu.sys) causes the issue:

*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

KERNEL_SECURITY_CHECK_FAILURE (139)
A kernel component has corrupted a critical data structure.  The corruption
could potentially allow a malicious user to gain control of this machine.
Arguments:
Arg1: 0000000000000003, A LIST_ENTRY has been corrupted (i.e. double remove).
Arg2: ffff80016eb9a480, Address of the trap frame for the exception that caused the bugcheck
Arg3: ffff80016eb9a3d8, Address of the exception record for the exception that caused the bugcheck
Arg4: 0000000000000000, Reserved

EXCEPTION_RECORD:  ffff80016eb9a3d8 -- (.exr 0xffff80016eb9a3d8)
ExceptionAddress: fffff809b0985c1b (ndis!ndisFreeNblToNPagedPool+0x000000000000006b)
   ExceptionCode: c0000409 (Security check failure or stack buffer overrun)
  ExceptionFlags: 00000001
NumberParameters: 1
   Parameter[0]: 0000000000000003
Subcode: 0x3 FAST_FAIL_CORRUPT_LIST_ENTRY

STACK_TEXT:
00 nt!KeBugCheckEx
01 nt!KiBugCheckDispatch
02 nt!KiFastFailDispatch
03 nt!KiRaiseSecurityCheckFailure
04 ndis!ndisFreeNblToNPagedPool
05 ndis!NdisFreeNetBufferList
06 rtwlanu!WDI_FreeRxFrame
07 rtwlanu!N6UsbWdi_RxReturnFrames
08 wdiwifi!CRxMgr::OnNdisReturnNetBufferLists
09 wdiwifi!CAdapter::ReturnNetBufferLists
0a wdiwifi!CPort::IndicateFrames
0b wdiwifi!CRxMgr::RxIndicatePortFrames
0c wdiwifi!CRxMgr::RxProcessAndIndicateNblChain
0d wdiwifi!CRxMgr::RxInOrderDataInd
0e wdiwifi!AdapterRxInorderDataInd
0f rtwlanu!wdi_NotifyPeerData
10 rtwlanu!WDI_NotifyDataInQueue
11 rtwlanu!RxNotifyThreadCallback
12 rtwlanu!Ndis6ThreadCallback
13 nt!PspSystemThreadStartup
14 nt!KiStartSystemThread

    Image path: \SystemRoot\System32\drivers\rtwlanu.sys
    Image name: rtwlanu.sys
    Browse all global symbols  functions  data
    Timestamp:        Tue Nov 15 17:34:02 2016

Because I see the callstack for the realtek driver, I see that you use the buildin driver of Windows. Get and install the latest driver from Realtek website.

| improve this answer | |
  • Actually I installed windows 10, then installed the LAN driver from the bundle I downloaded from the mobo's manufacturer, then I plugged in my Wifi NANO USB. – 4-K Jun 11 '17 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.