Suddenly, the devices on my LAN can't browse to the IPs or hostnames of other devices on the LAN (only to themselves and to the router at

I have a Win 10 desktop, a Macbook Air, an iPhone 6, and an old iPad, and they are connected to my wifi and are all browsing the internet fine on my Netgear WNDR3700 router with DD-WRT v3.0-r31924 std (05/02/17).

I'm also able to reach the config page of my router at from the devices.

Until a few days ago, they were also able to browse my LAN to show sites I'm developing on my local server (the Win 10 desktop at, which is also running Laravel Homestead Vagrant as another server, and everything had been working perfectly til recently).

Now, however, no device is able to connect to LAN IPs other than the router homepage at

I've tried rebooting the devices, rebooting my router and cable modem, restoring my router settings to an earlier version, etc.

Using the "Network Tools" app by KeepSolid on iPhone shows that Trace Route works for normal sites but then fails for LAN sites such as

The "Network Tools" iPhone app also has a DNS lookup utility. When I type in my local hostnames, they point to the proper IP addresses as the "A" record. Other records (AAAA, MX, NS, SOA, SRV, and TXT all say "DNS server returned answer with no data"). I don't really know what this means, and I guess it might all be irrelevant since hostname resolution is useless if my devices can't even visit an IP address directly in a browser.

I have no idea what changed this week... except somehow I noticed that my cable provider changed my WAN IP. But I really doubt that could cause these problems.

I discovered reports of a bug in the DD-WRT firmware on my Netgear WNDR3700 router.

People in that thread suggest that running the following commands in the router would be a suitable workaround, but none of their commands (such as these) has fixed the problem for me:

swconfig dev switch0 set enable_vlan 1
swconfig dev switch0 set apply

Plus, my router had been working, and I didn't make changes to it recently. So it doesn't make sense that this bug would be affecting me.

Plus, I also just tried replacing my Netgear router with an older TP-Link router (running a much earlier version of DD-WRT), and although that router had worked fine before, now even with that one, my devices can only browse the internet but can't ping LAN IPs.

What else can I try to diagnose and fix this problem?


Original Answer from 2017-05-30:

My sites are now all accessible again from all devices (even using my custom domains specified in DD-WRT).

Step 1:

I needed to go to Windows > HomeGroup and enable the PC to be discoverable on my network. (Maybe this was at Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings.)

(But how had my setup been working all along when my PC was not discoverable? Maybe it had been discoverable until recently? I'm not sure what would have changed its status. I don't remember ever setting it one way or another.)

Doing this enabled my Nginx site to be visible via mobile (rather than just in the browser of the same Windows desktop).

But then my Homestead (Vagrant) site still wasn’t visible via mobile (even though it still worked from the browser of the same Windows desktop). So...

Step 2:

I set these as startup commands in DD-WRT:

swconfig dev switch0 set enable_vlan 1
swconfig dev switch0 set apply

Step 3:

In DD-WRT > Additional DNSMasq Options, I changed address=/mysite.xyz/ to address=/mysite.xyz/

Other background info:

My Windows "hosts" file doesn't have any relevant active entries.

My Homestead.yaml is:

ip: ""
memory: 2048
cpus: 1
provider: virtualbox

authorize: ~/.ssh/id_rsa.pub

    - ~/.ssh/id_rsa2013Oct

    - map: c:/code/mysite-members
      to: /home/vagrant/Code/mysite-members

    - map: mysite.xyz 
      to: /home/vagrant/Code/mysite-members/public
      schedule: false

    - mysite

    - type: "public_network"
      # Should I make this network type public or private?
      # This IP must not match the static IP of the desktop. Make it different, such as "" if the desktop is
      ip: "" 
      bridge: "Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter"

And homestead.bat reload --provision is what I run if/when I ever edit Homestead configuration.


I wish I knew exactly what changed and why and what the root cause of the problem was.

All of my devices had been working perfectly until recently even without all of these steps.

Oh well. I'm glad it's all working again.

UPDATE on 2017-11-03:

I think I've encountered this problem three times over the past year, and I'm now thinking it has less to do with DD-WRT or any specific router or bug and instead could be related to IP address conflicts and IP addresses getting stale.

Today, during my latest encounter with this problem (using a Netgear R6300v1), I solved it by changing an IP setting from to in two locations (as previously described here).

The first location was Homestead.yaml > networks > ip:

ip: ""

    - type: "public_network"
      ip: ""
      bridge: "Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter"

In my DD-WRT "Additional DNSMasq Options", I changed it to address=/mysite.xyz/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.