17

I am currently having issues with sound redirection while using remote desktop connecting to a Windows 10 Pro Creators update host.

I am able to connect using RDP, however the hosts sound is not transmitted to the RDP session. I can see the 'Remote Sound' icon in the tray, and it shows when audio is playing with the volume bar.

Things I have tried:

  • Rebooting
  • Checking host and client volume control
  • Verifying that RDP client has 'Play on this computer'
  • Using different RDP clients to connect (Android/Windows Default/Windows Store)
  • Disabling Firewall/AV
  • Checking sound service / Remote Desktop service are started
  • Checked group polices for RDP sound redirection
  • Checked reg value for fDisableAudioCapture
  • Safe Mode (Unable to start required services in safe mode)

I have Realtek HDA audio drivers and NVidia audio drivers installed on the host, but that shouldn't affect the remote desktop sound redirection as far as I know.

Edit:

Also the drive redirection doesn't appear to be working, so it looks like an RDP issue rather than a sound issue.

I'd rather use RDP rather than other software like VNC

19

The solution to this problem was that the following service was disabled:

Remote Desktop Services UserMode Port Redirector

After enabling this service and setting to automatic (by pressing win + r and opening services.msc) all was working again.

Edit:

@SemVanmeenen in the comments mentions that restarting the Windows Audio service on the host fixed it for them, and it appears to fix the issue for a lot of other people too.

4
  • 16
    In my case, I needed to restart the service 'Windows Audio' on the host. – SemVanmeenen Aug 24 '18 at 9:37
  • @SemVanmeenen any chance you have experience with remote audio capture issue ? I have a server that I make remote connection to and there is currently after, windows update, no recording device, only sound play is working – serup Jan 16 '19 at 7:24
  • 1
    @SemVanmeenen That worked right after I restarted that service (called Audiosrv) with an active remote desktop session open. Thanks! – KristianB Nov 15 '19 at 13:30
  • @SemVanmeenen this was it! Restarting Windows Audio service worked! Thanks so much, I really struggled with issue a lot. – vatsug Sep 26 '20 at 9:25
7

As @SemVanmeenen mentioned, restarting the Windows Audio Services (I used the AudioEndpointBuilder as this is the root service) worked for me. This is a case I see often and results in Windows beeing unable to "pick up" the new device registered by the RDP Port Redirector.

Thus I think we're seeing different root causes here, as restarting the Audio Services forces the system to pick up the new Audio Devices, while the RDP Port Redirector creates those devices in the first place. This service of course has to be enabled for audio redirection to work

For the German users out there, the RDP Port Redirector is called "Anschlussumleitung für Remotedesktopdienst im Benutzermodus" in German in case you're looking for it...

1

In addition to all the above, in the RDP session, open volume control options, make sure the Remote Audio is checked.

0

I think these problem are created by a group directive.

First of all, try to connect from a different computer. If you have the same problem, then, it's a server problem, and probably, regedit problem or group directive stablished by the network administrator.

If your computer is on a windows Active Directory domain, tell this problem to the AD administrator.

IF you aren't on domain, check this registry value:

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

fDisableAudioCapture REG_DWORD 0 | 1

This key control the audio redirection. You need to check it on TS Server, not on the client machine.

1
  • This was already set to 0, updated question.I am able to see remote audio availble, just can't hear anything. – mt025 May 31 '17 at 19:35
0

I had a user whose PC was working fine with local audio, but would not play audio back to a remote session. Furthermore, programs attempting to do so were occasionally crashing (most notably, Windows' own Control Panel and Outlook).

Lots of head-scratching and digging led me to check the Event Viewer, which revealed the culprit: ff_acm.acm, a part of ffdshow, which is no longer maintained.

Changing ff_acm.acm and ff_vfw.dll (I'm guessing this was installed, somehow, as part of a video for windows codec pack?) to .old files in the system32 directory and giving the machine a reboot solved the issue.

0

For me restarting Windows Audio Service didn't work. I had to :

  1. Change [Session start] to "local system account", reboot and change it back to "This account".
  2. Select "Local Service" and put in my login password.
  3. Restart the service.

Sorry if the names are not accurate, my system is in Spanish.

PD: I think windows update did something to break it, was working before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.