0

I have a MacBook 7,1 and I am attempting to configure 2 ssd's in RAID 0, with a fresh install of (64)Mint 18.1 xfce on top.

I used this tutorial -> https://forums.linuxmint.com/viewtopic.php?f=46&t=138044#p735417

as reprinted in Full Circle mag Issue #104

Everything has been peachy until just before time to reboot. After chroot, it will not allow me to install Grub into my new filesystem. It gives me the error : cannot find EFI directory

sudo grub-install

-> this gives me the error: cannot find EFI directory

sudo grub-install --efi-directory=/boot/efi --bootloader-id=linux-mint

-> gives me error: /boot/efi doesn't look like an EFI partition

I have researched to the best of my noob ability and tried a couple things resulting in varying degrees of failure. If I simply reboot, not only can I not boot back up, but booting from the a LiveUSB shows that Mint was not even installed. It should be noted that I do not get the screen informing me to remove the installation medium and press 'enter'. I tried installing rEFInd instead, which seems to install ok and even allow the installation to complete upon reboot (although, still no 'remove medium and press enter' prompt) but then I cannot boot through rEFInd and must resort to my LiveUSB. I have no idea why this would happen if rEFInd was installed after chroot.

I am currently stuck post installation but pre-reboot, trying to install grub so I can restart to complete the Mint 18 install and reboot normally w/o the LiveUSB. Thanks you for any help. I am very much a noob so forgive me if I am all confused but I am determined to learn.

  • Please run the Boot Repair utility and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here. This will give us more details about your configuration, which is required to base an answer on more than guesswork. – Rod Smith May 29 '17 at 13:39
  • pastebin.com/C24Hs9Pz -Thank you very much. To be clear, I would just like to be able to boot using refind without needing to use my Mint liveUSB installer. – Jireh Athens May 30 '17 at 0:47
0

Your disks are improperly prepared. Specifically, to boot in EFI mode, you must have an EFI System Partition (ESP), and your disks lack this. When using Linux's software RAID, the ESP should be outside of your RAID configuration.

Also, your disks have a hybrid MBR configuration, which is ugly, dangerous, and unnecessary if you'll be booting in EFI mode.

  • Ok I see, problem is, I have tried every way possible to create an ESP (using gparted) but the installer will not let me finish the installation if I do this. Creating a FAT32 ESP partition (complete with esp/boot flag) at /dev/sda1 (outside of RAID) results in me receiving an error upon install; the installer fails to write the grub bootloader to disk and then immediately crashes. The only way I can conceivably complete install is with command ubiquity -b, however this leaves me in an unbootable state. – Jireh Athens May 30 '17 at 14:24
  • I have checked the integrity of my install medium, verified iso, recreated bootable usb, etc to no avail. I can wipe my disk and recreate this exact problem if necessary. As for Hybrid MBR, using gparted I formatted both ssd for GPT, so not sure how to avoid/change this. Any advice on how to proceed would be greatly appreciated. – Jireh Athens May 30 '17 at 14:24
  • Go ahead and install with the ESP and ubiquity -b, but install the boot loader of your choice manually afterwards. You can use rEFInd (on a USB flash drive or CD-R) to do a one-time boot, if that's necessary to complete the boot loader installation or if that simplifies matters for you. – Rod Smith Jun 1 '17 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.