3

Windows 10 will just not stop asking me for a password now I've added my microsoft account to the damn thing.

I added my MS account as I wanted to backup my key ready for wiping and reinstalling fresh.

Now, no matter what the settings in netplwiz or via the control panels 'Sign In Options' are set to.

Right now netplwiz is unticked. - After doing this i entered my microsoft account details, as it was showing the 'local' username rather than my account and I knew that account didn't have a password at all, thinking that was what was breaking this whole thing. It accepted my password without quibble.

I went back into the control panel and my 'Sign In Option' has always been set to never ask, and still is showing never ask.

Now, if I lock, sleep or reboot the machine it asks me to re-enter the long (And rather complicated) password again. As multiple users use this account I'm not going to expect them to all memorise it, nor am I going to create accounts for them. Is there some other setting I'm missing somewhere? I've found if I simply Remove my account altogether it goes back to accepting the local user with the blank password, however this just makes the whole backing up the key thing stupid.

[Edit]

Ok, after re-entering the settings - rebooting now works as expected - it logs in automatically, but if the machine sleeps/is locked, it doesn't log back in, instead asking for the password.

3

I was going to suggest to disable/reenable for the netplwiz, because I know from experience that you can do this with a windows live account, though figuring out the username could sometimes be a problem.

You figured this out already, so here is the remaining question:

Ok, after re-entering the settings - rebooting now works as expected - it logs in automatically, but if the machine sleeps/is locked, it doesn't log back in, instead asking for the password.

Yes, this is expected behavior. A computer gets locked when you lock or sleep. However, requiring a password at unlocking is a simple setting you can disable.

You can find it here:

Start Menu -> Settings (gear) -> Account -> Sign-In Options -> Require Sign-in.

Change this from "When PC Wakes up from Sleep" to "Never".

  • Yeah.... even with that option enabled, 'locking' the PC still does exactly that, however resuming from sleep is now ok. Is there someway to actually disable the lock behaviour? :D – djsmiley2kStaysInside May 30 '17 at 9:09
  • I don't think there is one. Although with the new Creators update, you can actually make windows automatically unlock based on peripherals such as a nearby phone. – LPChip May 30 '17 at 9:15
  • 1
    The only alternative I can think of is this: convert back to a local account, and remove the password. – LPChip May 30 '17 at 9:18
  • Yeah might have to do this, bit silly that locking the screen with a local account with no password allows you to unlock easily, but the moment it's a ms account you can't :/ – djsmiley2kStaysInside May 30 '17 at 9:50
  • Not silly, its because you cannot set a passwordless ms account. – LPChip May 30 '17 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.