16

All the time I have the problem that I cannot delete - move - rename folders in Windows 7 (also applies to windows 10) on network drives because of the thumbs.db file. It complains: "The action can't be completed because the file is open in Windows Explorer." I found something in a long thread that works for me.

2
  • You may also stop explorer.exe with taskkill and delete that folder with rd /s commands.
    – Biswapriyo
    May 30, 2017 at 4:36
  • Same problem on Windows 10, the workaround from lode also works there
    – NZD
    Jul 13, 2020 at 20:31

3 Answers 3

17

short answer:

windows 7: In explorer: Change file display settings from "details" to "Content"

windows 10: In explorer: View->Layout->List

Now the thumbs.db file can be removed.

Long answer:

https://social.technet.microsoft.com/Forums/windows/en-US/ca2cbc1a-362f-4f01-a8f8-6f05112f1915/windows-7-bug-explorer-locks-thumbsdb-in-most-recently-viewed-folder?forum=w7itprogeneral:

I accidentally came across a slightly easier fix for this bug. Instead of setting "Turn off the display of thumbnails and only display icons on network folders" to Enable, I simply changed the Windows Explorer display setting from "Details" to "Content". Then I was able to delete my Thumbs.db files without any complaints from Windows 7, even though I have thumbnails enabled. After deleting the offending file(s), I just restore the display to "Details" again.

thanks my unknown hero robster8192

4
  • 4
    Same problem on Windows 10, your workaround also works. The only difference is that there is no 'Content', but I used 'List' with the same result.
    – NZD
    Jul 13, 2020 at 20:32
  • Win10 on network folder: changing view from Details to List worked. However I did have to try twice. It might have been sufficient just to wait another couple seconds before attempting to delete. I 2nd the Kudos to @robster8192, thank you! Nov 8, 2022 at 23:39
  • The only solution that worked for me was in this answer by renaming the file first!
    – dashesy
    Feb 15, 2023 at 3:28
  • Doesn't work for me on W10 for a folder on a network share. ACK_stoverflow's solution worked (cut-paste the folder onto the desktop, then delete it).
    – mins
    Nov 19, 2023 at 13:32
7

I had this issue in Windows 11 on a network share, and none of the above solutions worked (changed view / layout, cut/paste on local machine).

However I was able to rename it to _.db, and then I was able to delete the file.

2
  • 2
    This is the only solution that worked for me, even on Windows 10.
    – dashesy
    Feb 15, 2023 at 3:28
  • Worked for all but one thumbs.db, that's already a progress, thanks for the tip.
    – mins
    Nov 19, 2023 at 13:23
4

I had this issue, but the file was on a Windows network share. Changing the view didn't allow me to delete the file. What I was able to do was to cut and paste the folder containing the Thumbs.db file to my local machine. Once I did that the folder and its Thumbs.db deleted without issue.

1
  • That worked for a network folder reluctant to Damian Vogel's solution (renaming into _.db). Thanks
    – mins
    Nov 19, 2023 at 13:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .