10

All the time I have the problem that I cannot delete - move - rename folders in Windows 7 (also applies to windows 10) on network drives because of the thumbs.db file. It complains: "The action can't be completed because the file is open in Windows Explorer." I found something in a long thread that works for me.

2
  • You may also stop explorer.exe with taskkill and delete that folder with rd /s commands.
    – Biswapriyo
    May 30, 2017 at 4:36
  • Same problem on Windows 10, the workaround from lode also works there
    – NZD
    Jul 13, 2020 at 20:31

2 Answers 2

15

short answer:

windows 7: In explorer: Change file display settings from "details" to "Content"

windows 10: In explorer: View->Layout->List

Now the thumbs.db file can be removed.

Long answer:

https://social.technet.microsoft.com/Forums/windows/en-US/ca2cbc1a-362f-4f01-a8f8-6f05112f1915/windows-7-bug-explorer-locks-thumbsdb-in-most-recently-viewed-folder?forum=w7itprogeneral:

I accidentally came across a slightly easier fix for this bug. Instead of setting "Turn off the display of thumbnails and only display icons on network folders" to Enable, I simply changed the Windows Explorer display setting from "Details" to "Content". Then I was able to delete my Thumbs.db files without any complaints from Windows 7, even though I have thumbnails enabled. After deleting the offending file(s), I just restore the display to "Details" again.

thanks my unknown hero robster8192

1
  • 3
    Same problem on Windows 10, your workaround also works. The only difference is that there is no 'Content', but I used 'List' with the same result.
    – NZD
    Jul 13, 2020 at 20:32
1

I had this issue, but the file was on a Windows network share. Changing the view didn't allow me to delete the file. What I was able to do was to cut and paste the folder containing the Thumbs.db file to my local machine. Once I did that the folder and its Thumbs.db deleted without issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.