1

I want to use Windows 10 with a Samsung ssd and a secondary internal hard drive. I just added the new ssd, but now the hdd can't be initialized and the ssd boot is so slow. I installed Windows 10 in the ssd without the internal hdd first, and added it after.

I noticed that If I remove the HDD from the Bios the laptop booted in seconds from the SSD, if I add the HDD it boots in minutes.

I think there is a recovery partition in this hdd that is making this happen. I thought linux would help me, so I want to format the hdd from an ubuntu live usb to fix it. I used gparted but It didn't work as expected.

In gparted, I selected my HDD and deleted all partitions, then formated it in NTFS. When I started Windows thinking the problem was solved, the HDD was recognized but the device can't be initialized, and Windows can't access the Hdd. It cannot be formated from Disk Management in Windows neither.

The hdd was fine before the ssd upgrade. What can I do?

EDIT: After unallocating space in my HDD from Ubuntu, I got this

http://imgur.com/a/Or19w

Right click, New simple Volumne, now shows an I/O error message and it does nothing...

Thanks

0

Boot to linux, remove the partitions on the old HDD, and leave it without any partition.

Boot into windows, and Disk Management should now be able to create a partition.

  • I tried what you said. The unallocate was Ok, but not the second step. I edited my question. – jpadilladev May 30 '17 at 19:39
  • Thats weird. The error would suggest the disk is about to die and needs to be replaced. – LPChip May 30 '17 at 19:42
  • The disk seems ok, Active Partition Recovery can access it (see imgur.com/a/bjfud) but I cannot create any partition. – jpadilladev May 30 '17 at 20:15
  • Yes, windows can access it too and can't create any partitions either. Something in the disk seems to be corrupt. If Linux can still create partitions, you should look into creating NTFS partitions, but it may very well be that linux did something to the disk that the rest is now having trouble with. – LPChip May 30 '17 at 20:43
  • Just created a partition in ubuntu, I had to use this answer askubuntu.com/a/562147/228467 to be able to do it: imgur.com/a/MM4A6 Now I need to see if I can use it on Windows... – jpadilladev May 30 '17 at 20:44
0

I answer myself.

I reconnected my internal hdd physically, in case it was disconnected.

Then, things went better. I cannot create the partition from Disk Management, but I used the following commands to create the partition

diskpart

list disk

select disk 0

clean

create partition primary

select partition 1

format fs=ntfs quick

Then I used a Disk Partition tool like Active Partition Manager to rename my device.

Thanks

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.