17

The recent large Windows 10 update (~ May 2017) has changed the behavior of my laptop's power management and security.

I use the blank screensaver for a couple minutes, and then just have the monitor turn off a couple minutes after that. Because why bother even powering the monitor when it's just blank anyway.

Previously I could just move the mouse/trackpad/anykey and the monitor would turn on and I could resume working. However the latest Windows 10 update has changed this behavior and now locks the OS whenever the monitor turns off. I'm sure this was implemented for Win10 mobile devices, but it's a big PITA for a laptop or desktop computer. If I want my computer locked, I'll lock it or put it to sleep.

Is there a way to disable this behavior? I've not been able to find any way to change it using standard settings. Something in the registry maybe?

Edit: This is a laptop computer with a touchscreen.

Edit 2 - Clarifications:

  • The computer does NOT enter sleep mode, however it is configured to lock when it does sleep
  • It is NOT a screen saver lock - the screen saver is set NOT to lock, and does not do so
  • The computer is NOT in tablet mode, however Windows seems to use tablet behavior when the monitor is turned off
  • If you are referring to Creators update, it just resets your setting to default. You can configure your screensaver and power management setting back to your usual setting. – Vylix May 30 '17 at 21:36
  • 1
    try the solutions mentioned in this question superuser.com/questions/398015/… – xypha Jan 4 '18 at 2:24
  • What in the Device Manager are the Power Management settings of the mouse/trackpad/keyboard, and especially "Allow this device to wake the computer" ? – harrymc Jan 4 '18 at 14:21
  • @harrymc Of all the input devices, the only ones with power management options are: Human Interface Devices -> USB Input Device (of which there are 3), and Airplane Mode Switch. On all of them, "Allow this device to wake the computer" is not checked, and greyed out such that it cannot be modified. Also, to clarify, the computer never goes to sleep, but the monitor turns off to save power. All input devices cause the monitor to turn back on. – ulty4life Jan 4 '18 at 21:18
  • 1
    @ITSnuggles: You're welcome to use any information which I solicit from the user. – harrymc Jan 6 '18 at 9:54
4

Had this issue, fixed it by doing:

Click on Start and type: Lock Screen Settings. In Lock screen - click on 'Advanced slideshow settings'. In Advanced slideshow settings - there is a setting: 'When my PC is inactive, show lock screen instead of turning off the screen' that was set to ON, change it to OFF.

| improve this answer | |
  • 1
    Hey, thanks for responding. I just tried changing this setting, even though I don't use the slideshow feature, and it seems like it may have worked. I'll verify later with some actual tests and give an update. 2 years ago since I posted this question, and it would be great to get it resolved :) – ulty4life Jun 28 '19 at 3:17
  • After I toggled this setting on/off, my display and lock screen settings function as intended. I actually can't even replicate the issue I was having by turning it back on and switching back to windows spotlight mode. Seems like a default setting that MS must have pushed down that got tangled up in my configuration. Thanks! I'm glad this issue is finally fixed. And thanks to everyone else for helping to try and figure it out. – ulty4life Jun 30 '19 at 2:41
  • 4
    There is no 'Advanced Slidesow Settings' – niico Sep 17 '19 at 5:39
  • 1
    Just in response to @niico and any others with the same issue, if you can't see 'Advanced Slideshow Settings', change the 'Background' from Windows Spotlight or Picture to Slideshow. The settings should then appear below where you can pick albums :) – Brady W Feb 28 at 5:16
  • Registry location for this setting: HKCU\Software\Microsoft\Windows\CurrentVersion\Lock Screen\SlideshowAutoLock – pholcroft May 22 at 7:38
6

Windows Key->Settings->type "lock screen" in search bar, click "Screen saver settings". Uncheck "On resume, display logon screen".

If I want my computer locked, I'll lock it or put it to sleep.

Implies your computer is not asleep. However, sleep also has a lock option.

Windows Key->Settings->type "Sign" in the search bar, click "Sign-in options"->Change "Require sign-in" from "When PC wakes up from sleep" to "Never"

I have seen Windows update re-enable sign in requirements.

As Arana points out, in addition, there's a logon setting in the screen saver. Windows Key->Settings->type "Lock" in the search bar, click "Lock screen settings"->Screen Saver settings. This load the screensaver dialog. Ensure "On resume, display logon screen" is unchecked.

This is anecdotal at best, but, I used to have a dell laptop, and for quite a while I could not use the "turn off monitor after..." setting prior to sleep or the monitor would never work (remained black) unless I performed a hard reboot. While I had visited the dell site many times for updates, I finally tried going directly to the video card vendor (AMD if I recall correctly) and I found an update not on the Dell site for the integrated motherboard graphics and after installing, this feature started working again.

| improve this answer | |
  • 1
    That checkbox is already unchecked. – ulty4life May 30 '17 at 23:07
  • So check it, ok ok ok. Then uncheck it, ok ok ok – HackSlash Jan 5 '18 at 19:33
  • @HackSlash did that. no effect. – ulty4life Jan 5 '18 at 21:34
  • a long shot here but is you screen saver seting "On Resume Display Logon Screen" Checked? Also Are you using your windows OS with a linked MS Account? , I ask this because your settings may be synching with another device which has the option you mention turned ON. – arana Jan 9 '18 at 23:57
  • 1
    @arana it's definitely not the screensaver that triggers it, but the monitor being turned off. These two events happen at separate times. I do use this logon with another computer, but it doesn't lock on the screen saver either, and it can't turn off the monitor as it's a television. The linked account saved settings is interesting though. Do you know if there's a way to view saved settings in a MS account via e.g. an MS account profile web page? – ulty4life Jan 12 '18 at 4:11
5
+25

Major Windows upgrades can cause various problems, not all of them can be corrected by anything other than a full reinstallation. Below is my analysis of the problem.

I didn't find anything unusual in your report of powercfg -energy, so in my opinion your computer's settings and drivers seem not to show any visible problem. For this reason I wouldn't recommend updating the BIOS, as mentioned in the comments, as the benefits are unknown but there is always the risk of an unsuccessful BIOS update bricking the computer.

You say that you "use the blank screensaver for a couple minutes, and then just have the monitor turn off a couple minutes after that". As you don't want the computer to sleep or lock, I see no reason for having a screensaver at all. Turning it off might be a first step for isolating the problem.

Another long shot, but which sometimes helps to resolve sleep problems, is to Turn Off and Disable Hybrid Sleep in Windows. This is another step for isolating the problem, although the chances of it helping might be slim.

My last idea is based on your observation that "another user account on this same computer that functions the way I want it to". This might indicate profile corruption, probably caused by the Windows upgrade. This kind of problems are extremely hard to diagnose, and might not be worth the trouble.

The usual solution is to migrate to a new and uncorrupted user profile. Many articles have been written on the subject, for example Fix Windows Issues by Creating a New User Account. If the new account solves the problem, you won’t need to do a Reset, Restore, Refresh or reinstall of Windows.

| improve this answer | |
  • I'll create a new user account and configure it the same way and check it's behavior. That way I'll have a fresh on to use as a baseline to compare behavior against they two that I use. – ulty4life Jan 6 '18 at 22:56
  • 1
    A newly created user account behaves as expected. – ulty4life Jan 12 '18 at 4:13
  • When I have some spare time I'll try to do a little more analysis to compare the new account with my current account to see if I can find any differences. I'll look into migrating account profiles, as that may be the only way I can fix this if nothing else comes to light. – ulty4life Jan 15 '18 at 21:29
  • The problem with analyzing user profiles is that not all settings are documented. – harrymc Jan 15 '18 at 22:34
2

Finally got a call with Microsoft over this issue, and they found a solution for us. We were having this same issue - on Win7, we had the monitor set to turn off after 5 minutes, but screen saver after 15 (which is what would lock the screen). In Win10, it was locking after the screen turned off, at 5 minutes. This only occurred on domain-joined machines.

There is an obscure policy that affects this. To get your Win10 machine to behave like the Win7 machine did (stay unlocked after the screen turns off), Enable the following policy:

Computer/Administrative Templates/System/Logon/"Allow users to select when a password is required when resuming from connected standby"

| improve this answer | |
1

You can set in Sign-in options Require sign-in to Never, and when putting computer to sleep, get it locked first and then go to sleep (Windows key+L, power button(if you set it that way)). Require sign-in - Never isn't quite never, if you manually lock it, it will require sign-in anyway.

That's not a solution, but works like it is (almost). The only thing that's not working in this case is when computer wakes up from sleep, without being locked before it went to sleep, it won't require sign-in on wake up...

| improve this answer | |
1

I got the same issue in windows 10 go to cortana and type secpol.msc then go to Local Policies folder, then Security Options, then find Interative logon: Machine inactivity limit click twice to open it and change the number in seconds for example 57600 will give 11 hours or you can set it to the highest 599940 after this go to cmd and type gpupdate after is done re-start your pc and enjoy no logout from your account :)

| improve this answer | |
1

If you are unable to change the Sign in requirement due to it being gray / grey disabled, set

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power]

to

"CsEnabled"=dword:00000000

And a reboot allowed me to change the greyed / grayed setting.

| improve this answer | |
-1

Try to run this from command prompt as Administrator:

REG ADD HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Personalization /f /v NoLockScreen /t REG_DWORD /d 1

This will create a new entry in registry that should disable the Lock Screen in Windows 10.

If you want the lock screen on again, just change the "1" to "0"

I have taken it from here: https://windows.gadgethacks.com/how-to/disable-lock-screen-windows-10-0162965/

Note on Disabling the Windows 10 Login Screen & Password Prompt

On a related note, it is possible to disable the Windows 10 login screen so that you don't have to enter a password after booting your PC, but that subject would warrant a separate tutorial, and it comes with one big downside: If you disable the password prompt and login screen on Windows 10, you'll lose the ability to sync settings and data across all of your Windows devices. Hopefully this process becomes a bit more stable in future builds, and we'll cover it at that time.

(Did not tested this myself)

| improve this answer | |
-1

Try this...

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Power\PowerSettings\0E796BDB-100D-47D6-A2D5-F7D2DAA51F51] "ACSettingIndex"=dword:00000000

I looked everywhere to find this and tested it for myself.

| improve this answer | |
  • Are you sure that is the correct registry key? That is only suppose to apply if the machine goes to sleep, with a value of 0, the machine will be unlocked and insecure. This policy does not determine if the machine will be locked if the monitor goes to sleep – Ramhound Feb 27 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.