1

I have an MSI GE62-2QD laptop running Windows 10 v1607 (build 14393.0) with an Optimus graphics configuration (GTX960m discrete and Intel HD Graphics 5600 on an i7-5700hq).

Occasionally, the laptop encounters overheating (about 90 degrees) and begins to throttle by limiting CPU frequency to about 800MHz, until cores drop to 89 degrees. However, when throttling occurs (for example in a game that is using the NVidia GPU), the Intel XTU utility reports that the power consumed by the Intel graphics coprocessor jumps dramatically, from 1-4W to about 18W. This additional power consumption causes the temperature of the die to continue to rise, making it hard to break out of the overheat situation.

I've already tried to clean and replace fans, as well as re-seat the heatsink with new MX4 thermal paste (cleaning all surfaces with the recommended cleaning processes), which has kept temperatures slightly lower but still causes occasional thermal throttle events.

This additional Intel GPU power consumption does not make sense, since I'm not running any GPU-intensive processes that utilize it, and it shouldn't be receiving any additional load. According to Intel XTU, the graphics frequency is as low as 200MHz during the throttle events, and running GPU stress tests on the Intel GPU doesn't lead to such high power consumption when the system is not throttling. Additionally, on Linux (dual-boot), the system recovers from throttle events almost immediately, leading me to conclude that the issue is not present at that time.

I've attempted to use Throttlestop's BD PROCHOT flag (as well as other parameters such as max graphics frequency, graphics undervoltage, etc) to no avail. The NVidia GPU (unaffected by this) has no cooling problems.

Is there any known fix for this?

  • BD PROCHOT? techpowerup.com/download/techpowerup-throttlestop – bwDraco May 31 '17 at 3:43
  • @bwDraco I'll try it, thanks. However, the Intel GPU is not the cause of the overheating; if it continued to operate at the same clock/voltage/power the throttle would not be an issue. Will edit post once I test this. – hexafraction May 31 '17 at 3:55
  • @bwDraco No luck, with BD PROCHOT runaway power usage still occurs once the thermal threshold is tripped. Attempted updating all Intel drivers as well, to no avail. – hexafraction Jun 1 '17 at 4:38
  • If you click the Intel HD Graphics driver tray icon, select Graphics Properties, 3D tab, do you have a performance slider that you can set to less? – harrymc Jun 7 '17 at 8:33
  • 1
    That's a tall order and the info is probably impossible to find. Are you using the latest MSI drivers? (Even if they are not very recent). You could also use a cooling pad. – harrymc Jun 10 '17 at 6:59
2
+50

The MSI GE62-2QD laptop is known for overheating, because its specs were possibly too ambitious for a laptop with not enough cooling fans or air passages.

As one user testimony says for a similar model:

On my machine (GE72 2QF) I find that, when I use 4 heavy processes (which would load 4 physical cores to 100%) I got temperatures in 70s C range and CPU works at maximum frequency of 3.5GHz, but as soon as I put load on other logical cores, temperature rises very rapidly to 90+C and CPU starts to throttle to as low as 2.5GHz (and quite honestly, benefits of HT are gone at this point (I mean performance of 8 logical cores at 2.5GHz vs performance of 4 physical cores at 3.5GHz)).

The usual advice is :

  • Hardware : Invest in a cooling pad.
  • Windows : In Control Panel -> Power options -> Change plan settings -> Change advanced power settings, expand Processor power management and set the Maximum processor state to 98% for Battery and Plugged in. This shouldn't noticeably hurt gaming performance, but should lower the CPU temperature (reduce some more if required).
    You could also try to disable HyperThreading by limiting the number of available processors to Windows (run msconfig in Boot / Advanced options).
  • Thank you for submitting an answer. Unfortunately I'm already doing both of the things you mention (limiting cpu power state through a number of different configuration options available to me, and using a high-flow cooling pad). I'll try older driver revisions for any relevant drivers to see if any do not suffer from the power mismanagement that I mentioned before, and keep the bounty open for another day in case a fix comes my way. – hexafraction Jun 10 '17 at 14:24
  • A different driver might make a difference, but I don't believe in it as a complete solution. I think you have a laptop that is running too hot by design, so you will need on the one hand to improve the airflow and on the other to reduce maximal resource usage. – harrymc Jun 10 '17 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.