11

Somehow Win+Right and Win+Left shortcuts that are used to snap the window to the left or right of the screen don't work any more. They worked fine a few days a go and now the stopped working.

Other Windows key shortcuts work fine, the the arrow buttons work fine.

What can be the problem?

1
  • Did you install windows powertoys ?, because some people have faced this problem due to it.
    – Valay_17
    Dec 1 '19 at 1:02
8

It's because the snap option has been disabled. Just open start menu, type Snap and select Snap settings. Alternatively open settings > system > multitasking

There you'll see the Snap - Arrange windows automatically by dragging them to the sides or corners of the screen. Just enable it and the shortcuts will work again

snap

See also

3
  • I had the same issue. This fixed it for me. I had installed the Dell monitor management software for my computer and it had disabled snap. Thanks!
    – evilhomer
    Jan 28 '20 at 12:42
  • I'm experiencing the same issue except that Snap and all successive checkboxes are toggled on. Any ideas?
    – Chad
    Jan 30 '20 at 2:05
  • @Chad try the solutions in this question. If it doesn't help then you'll need to ask another question
    – phuclv
    Jan 30 '20 at 2:10
2

If you close a window that is currently snapped then re-open it, it generally breaks one of the snap directions. e.g. if I snap VSCode to the right side of my screen, close it, then re-open it, Win+Right will work, but Win+Left will not.

1
  • 1
    I have been running into this as well, and I've found the behavior very confusing. Thank you for at least explaining how to consistently repeat the issue, and at least give me a way to "correct it". When this happens, I'm able to un-snap the window and close it. Then both Win+Right and Win+Left work again. Jan 28 at 4:37
1

Find Multitasking Settings and switch Snap on.

3
  • 2
    Please clarify and add a little more context to this answer to convey what you are suggesting exactly. You know, consider adding some reference to this answer supporting what you state. Aug 11 '17 at 16:49
  • I have the exact same problem as OP. Here are my snap settings: imgur.com/a/iSaPX
    – George
    Nov 9 '17 at 6:27
  • Update: for me the problem was solved after a reboot
    – George
    Nov 9 '17 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.