12

I found that when attempting to change the Date/Time settings on a Hyper-V virtualised Windows 8 OS, I found that the date would immediately change back to the correct date.

How can I prevent the Date/Time from reverting once I've set it?

1
  • 1
    With PowerShell:: Disable-VMIntegrationService –Name <Service Name> -VMName <Target Guest VM Name> – Biswapriyo Jun 22 '17 at 14:46
14

Open the 'Hyper-V Manager' application on the host machine.

On the list of 'Virtual Machines', right-click on the VM where you want to change the Date/Time settings and click 'Settings'.

Under the 'Management' section of options, select 'Integration Services', and uncheck the 'Time synchronization' option.

enter image description here

When changing the Date/Time settings from within the VM, the Date/Time will no longer revert to the Date/Time on your host machine.

1
  • 2
    You might want to include the warning that time keeping in VM's without this can be very iffy.... – djsmiley2kStaysInside Jun 1 '17 at 8:38
-1

It is possible to temporarily disable time synchronization for hyper-v vm's however every hour or so the OS will sync with the hardware clock aka the bios time. As far as i known its not possible to change the bios time for hyper-v vm's. if you disable the windows time service, the hyper-v time service and task scheduler time synchronization jobs, the OS will sync the system time to the bios clock roughly every hour.

https://answers.microsoft.com/en-us/windows/forum/all/access-bios-settings-system-date-for-vm-in-hyper-v/62f4ea6b-7bdb-433b-83d3-3fd03fd4978a

I ended up just creating a virtualbox vm and using the bios time offset command https://winaero.com/blog/how-to-set-the-bios-date-in-virtualbox/

hopefully this feature will be implemented in the future for hyper-v.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.