I have ASUS nettop with WiFi adapter and want to use it as hotspot.

       description: Wireless interface
       product: QCA9565 / AR9565 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: ****
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.16.0-4-amd64 firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f7d00000-f7d7ffff memory:f7d80000-f7d8ffff

Available Antennas: TX 0x1 RX 0x3
Configured Antennas: TX 0x1 RX 0x3
Supported interface modes:
     * IBSS
     * managed
     * AP
     * AP/VLAN
     * WDS
     * monitor
     * mesh point
     * P2P-client
     * P2P-GO

Adapter seems to be loaded successfully, but I can't see it among wifi hotspots from my Android mobile phone

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

eth1      no wireless extensions.

eth0      no wireless extensions.

I have set up hostapd as described here but without bridged connection because I don't need it right now.

What could possible be the reason my hotspot can't be actually discovered?

UPD: I've listed hostapd errors while start, but still don't know what does that mean, what's exactly the problem with driver:

sudo hostapd -d /etc/hostapd/hostapd.conf 
random: Trying to read entropy from /dev/random
Configuration file: /etc/hostapd/hostapd.conf
rfkill: initial event: idx=0 type=2 op=0 soft=0 hard=0
rfkill: initial event: idx=1 type=1 op=0 soft=0 hard=0
nl80211: TDLS supported
nl80211: TDLS external setup
nl80211: Supported cipher 00-0f-ac:1
nl80211: Supported cipher 00-0f-ac:5
nl80211: Supported cipher 00-0f-ac:2
nl80211: Supported cipher 00-0f-ac:4
nl80211: Supported cipher 00-0f-ac:6
nl80211: Using driver-based off-channel TX
nl80211: Use separate P2P group interface (driver advertised support)
nl80211: interface wlan0 in phy phy0
nl80211: Set mode ifindex 3 iftype 3 (AP)
nl80211: Setup AP(wlan0) - device_ap_sme=0 use_monitor=0
nl80211: Subscribe to mgmt frames with AP handle 0x7f5679770d80
nl80211: Register frame type=0xb0 (WLAN_FC_STYPE_AUTH) nl_handle=0x7f5679770d80 match=
nl80211: Register frame type=0x0 (WLAN_FC_STYPE_ASSOC_REQ) nl_handle=0x7f5679770d80 match=
nl80211: Register frame type=0x20 (WLAN_FC_STYPE_REASSOC_REQ) nl_handle=0x7f5679770d80 match=
nl80211: Register frame type=0xa0 (WLAN_FC_STYPE_DISASSOC) nl_handle=0x7f5679770d80 match=
nl80211: Register frame type=0xc0 (WLAN_FC_STYPE_DEAUTH) nl_handle=0x7f5679770d80 match=
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x7f5679770d80 match=
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=0): [NULL]
nl80211: Could not configure driver mode
nl80211: Remove monitor interface: refcount=0
nl80211: Remove beacon (ifindex=3)
netlink: Operstate: ifindex=3 linkmode=0 (kernel-control), operstate=6 (IF_OPER_UP)
nl80211: Set mode ifindex 3 iftype 2 (STATION)
nl80211: Teardown AP(wlan0) - device_ap_sme=0 use_monitor=0
nl80211 driver initialization failed.
hostapd_interface_deinit_free: num_bss=1 conf->num_bss=1
hostapd_bss_deinit: deinit bss wlan0
hostapd_cleanup(hapd=0x7f5679771700 (wlan0))
hostapd_free_hapd_data: Interface wlan0 wasn't started
hostapd_interface_deinit_free: driver=(nil) drv_priv=(nil) -> hapd_deinit
hostapd_interface_free: free hapd 0x7f5679771700
hostapd_cleanup_iface: free iface=0x7f56797703c0
  • Your wireless chipset might not be capable of providing a hosted/access point network mode so your efforts might be in vein...
    – Kinnectus
    Jun 1, 2017 at 15:32
  • @big Bloody good remark.
    – xenoid
    Jun 1, 2017 at 19:42
  • this is working for men. does not require it reboot unix.stackexchange.com/questions/339087/…
    – Toir
    Nov 14, 2018 at 8:00

1 Answer 1


Found the problem, it was in hostapd.conf, maybe it will help someone:

I used hostapd.conf settings from this post while it seems to be wrong or deprecated, after I looked through Hostapd Howto here I've noticed that there is another way to specify driver for hostapd, I replaced driver=nl80211 with ieee80211n=1 in hostapd.conf and hotspot started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.