CONTEXT: Windows 7 Power Settings

Last night I was running a lengthy series of jobs: the intent was to have them run overnight: the machine is plugged-in and NOT running on battery power. I woke up this morning to find the PC had been put into sleep mode for some reason and the jobs were NOT finished.

Is there another setting that needs to be considered or is there a good place to start troubleshooting as to why the machine shutdown on its own?

Any suggestions to improve the question is appreciated. I can not be the only person to suffer this problem: re-opening with an improve question will help future users

  • This is a laptop? If yes, had you closed the lid? – CharlieRB Jun 2 '17 at 14:23
  • Good question: no the lid was never closed. That would invoke sleep mode and prevent overnight execution of the jobs – gatorback Jun 2 '17 at 14:35
  • "is there a good place to start troubleshooting as to why the machine shutdown on its own?" Yes, the event logs. – Ƭᴇcʜιᴇ007 Jun 2 '17 at 14:57
  • When you click on Change advanced power settings you have 2 options that you need to check: sleep = never and hard-disk= never turn off. – Alex Jun 2 '17 at 15:30
  • 1
    There are several power settings that need to be checked/modified by going to the advanced power settings, as I stated in my previous comment. – Alex Jun 2 '17 at 17:49

Check the advanced power plan settings by clicking on Change advanced power settings: enter image description here

In the menu that opens you have to check if your HDD is set to turn off after 0 minutes (never): enter image description here

and if Sleep and Hybrid sleep are off:

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.