143

I'm always accidentally minimizing most of my windows. This is really annoying. How do I disable Aero Shake?

  • 1
    What is Aero shake? – asjo Jul 25 '09 at 1:53
  • 2
    You can grab an application window by the titlebar and "shake" it to minimize all other applications. istartedsomething.com/20081103/… – Jared Harley Jul 25 '09 at 3:40
  • 28
    It's also worth mentioning that you can re-shake the window to bring all the windows back up. I was looking to disable the feature until I discovered that. – Phil Mar 5 '12 at 17:08
  • 2
    Why do companies have to brand things like this. Aero shake, seriously? Why not Shake 2 Min or Shake 2 Hide – Alan B. Dee Mar 6 '13 at 16:31
  • 2
    // , That might be a good question for marketing.stackoverflow.com, @AlanB.Dee. meta.stackexchange.com/questions/2987/… – Nathan Basanese Sep 1 '15 at 16:22
164

The best way to do this is to use the Group Policy editor. Go into the start menu, type in gpedit.msc, and hit enter. When it comes up, go into User Configuration -> Administratrive Templates -> Desktop.

In here you'll see a settings called "Turn off Aero Shake window minimizing mouse gesture". Set this to enabled and no more Aero Shake.

Here's a picture of the Group Policy Editor, with the setting highlighted:

Group policy editor screen for disabling Aero Shake

Another option is to edit a key in the registry. If you don't have Group Policy Editor for some reason (lower end Windows 7 edition), this might be your only option. There's a downloadable reg file that will handle this automatically from the How-To Geek.

  • Either that or edit the registry. I prefer this method. – TheTXI Jul 24 '09 at 13:00
  • 1
    Added that in. I figure the Home editions of 7 might not have Group Policy Editor like in Vista. – スーパーファミコン Jul 24 '09 at 13:19
  • What's funny is that I had to memorize stuff like this for my windows 7 cert (70-680) two years ago. Today I couldn't remember this part. – Alan B. Dee Mar 6 '13 at 16:26
  • 4
    +1, especially for the screenshot - makes it really easier to find this if the Windows language != en – Martin Nov 17 '14 at 10:32
  • 2
    Note that this requires administrator privilege. For a standard user, Cheran's solution may be more suitable. – Harry Johnston Jan 22 '16 at 0:55
23

If you don't mind turning off Aero Snap (which resizes your windows when you drag the title bar to the top or sides of the screen), then you can turn off Aero Shake through the Ease of Access Center:

It is possible to turn off this feature, though the setting to do so is not readily apparent. Here’s what you need to do:

  1. Click the Start button to open the Start menu.
  2. Type mouse in the Search Files And Programs box.
  3. Select Change How Your Mouse Works from the list of items that are found.
  4. Select the checkbox for the option Prevent Windows From Being Automatically Arranged When Moved To The Edge Of The Screen.

Note that this will also disable the Aero Shake feature, which lets you shake a window to minimize all other open windows.

(source, emphasis on the last sentence mine)

  • 3
    Two birds with one stone! – Mr Fooz Jan 23 '14 at 15:24
  • 3
    Note that this also disables the Control-Shift-Arrow keyboard shortcut. – Harry Johnston Jan 24 '16 at 23:02
  • 3
    This is a better answer for when you don't have access to group policy or registry. For example, a lot of companies only allow limited privileges over certain settings like this. – Conor Gallagher Apr 12 '16 at 11:14
  • You sir, saved my office window from having a chair being thrown through it. – Owl Sep 8 '17 at 15:24
2

If you don't want to touch the registry (or GPE), download Ultimate Windows Tweaker which allows you to to turn it off in the 'Personalization' settings (along with lots of other TweakUI type stuff).

2

As some editions of Windows do not include the Local Policy Editor, and importing a .reg (without inspecting it) doesn't quite show you what it does, I'd like to chime in with a method to change this setting from the command-line.

Check current state (you will get an error if the value doesn't exist, in which case Aero Shake is enabled)

reg query "HKCU\Software\Policies\Microsoft\Windows\Explorer" /v "NoWindowMinimizingShortcuts"

Disable Aero Shake

reg add "HKCU\Software\Policies\Microsoft\Windows\Explorer" /v "NoWindowMinimizingShortcuts" /d 0x1 /t REG_DWORD /f

Return to default setting for Aero Shake (Enabled)

reg delete "HKCU\Software\Policies\Microsoft\Windows\Explorer" /v "NoWindowMinimizingShortcuts" /f

Hope this helps!

  • Does that need a logout? After adding the key via an admin command prompt, Aero Shake still works in my Windows 10. – Cees Timmerman Nov 30 '18 at 17:19
  • This does not require you to log out. Immediately after applying the registry key the change should be active. – Inny Mar 4 at 15:17
1


Another way to disable shake AND the auto arrange that occurs when bumping a window against the outside edge of the screen in Windows 7:

(1) Right-Click on your Desktop and Select "Personalize".
(2) Select "Make the mouse easier to use".
(3) Check the box that reads "Prevent windows from being automatically arranged when moved to the edge of the screen".
(4) Click "Apply" then "OK".

This will disable both shake and auto arrange from edge of screen.

  • Perfect! On Windows 8.1, another step is needed between 1 and 2: In the "Personalisation" window, click "Ease of Access Center" at the bottom left. – Sphinxxx Nov 11 '15 at 18:53

protected by Community Apr 19 '15 at 12:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.