3

For some reason, whenever I open Adobe Acrobat Pro DC, the icon that displays for it on my program tray is wrong.

Adobe Acrobat Pro DC Showing Incorrect Icon

The icon that displays in place of the Adobe Acrobat icon is for a program called "icofx" that I have installed on my computer, but icofx displays its icon properly. Adobe Acrobat is also the only program that seems to be doing this. How can I fix this? I am running Windows 10.

  • Try reinstalling Acrobat. – DavidPostill Jun 4 '17 at 16:26
  • 1
    I also face that problem. Try to delete and rebuild Windows explorer thumbnail cache. Or make a shortcut and pin/unpin it in taskbar. – Biswapriyo Jun 4 '17 at 17:14
  • @DavidPostill Unfortunately that did not resolve the problem. – DaveTheMinion Jun 4 '17 at 18:15
  • @Biswa Pinning the shortcut did not work, as it still shows the incorrect icon. It looks like I will rebuild the cache. Out of curiosity, is Acrobat showing the icofx icon for you as well or is it a different program. I'm trying to figure out if it's icofx-specific or if it's just a general bug. – DaveTheMinion Jun 4 '17 at 18:16
  • @DavidB Have you tried rebuilding Icon cache ? – pun Jun 4 '17 at 18:57
6

I found this answer at http://efanzh.org/2016/06/09/fix-adobe-acrobat-reader-start-menu-icon.html.

If you were to navigate to: %SystemRoot%\Installer\{AC76BA86-7AD7-1033-7B44-AC0F074E4100} you'd see that all the .ico files there are the wrong icon.

He says to change your default .ico viewer to MS Paint (for all of Windows). When I did that, sure enough, the icon was fixed.

| improve this answer | |
  • Okay, thanks for sharing. I will have to try this. I never did fix the problem because I got tired of trying to. – DaveTheMinion Feb 15 '18 at 15:38
1

I believe the underlying reason is the Adobe MSI installer breaks Microsoft's rules for creating a Windows installer package. Under the documentation, we read:

Icon files that are associated with shortcuts must be in the EXE binary format and must be named such that their extension matches the extension of the target.... For example, if a shortcut is to point to a resource having the key file Red.bar, then the icon file must also have the extension .bar.

(https://msdn.microsoft.com/en-us/library/windows/desktop/aa369210(v=vs.85).aspx)

In the MSI installer for Adobe Reader DC / 2015 / 2017 we see the 'Icon' table entries, all of which have the extension '.ico' by default:

Adobe Acrobat Reader DC Icon table

If you edit the MSI with Orca and do a find/replace to change '.ico' to '.exe' on every relevant table, and then repair / reinstall the MSI, the problem does not reoccur. It would be helpful for Adobe to fix this in the MSI directly for everyone in another release.

| improve this answer | |
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Apr 15 '18 at 20:17
  • Alright well that's kind of annoying. Thanks for sharing! I still haven't bothered to fix this problem. It bothered me at first, but then I got used to it. Even so, it only happens on one of my computers even though I have several that are configured the same way. – DaveTheMinion Apr 15 '18 at 21:21
0

This looks similar to the issue I encountered with Adobe Acrobat pro.

To fix this try the following:

Navigate to where Adobe Acrobat DC is installed i.e C:\Program Files\Adobe\Acrobat 11.0\Acrobat\Acrobat.exe (note: since I'm using Adobe Acrobat pro not DC , in your case navigate the executable of Adobe DC Pro

The main goal is to create a shortcut of the correct Adobe Acrobat DC Pro.

You can export this shortcut to desktop by right clicking and choosing "send to desktop"

Next step, navigate to C:\ProgramData\Microsoft\Windows\Start Menu\Programs

If you scroll you will see that bad icon named Adobe Acrobat DC Pro in that folder.

Now rename the shortcut on desktop to match the name of the bad icon in above folder.

After that copy the proper shortcut and replace that bad icon in the above folder.

This should fix the problem

| improve this answer | |
  • Remember to first unpin the wrong icon from taskbar then follow the anove steps – xavier_fakerat Jun 4 '17 at 19:01
  • May you kindly provide feedback whether this workaround solve your issue, if yes please be sure to mark as answer. – xavier_fakerat Dec 22 '17 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.