2

I have a Windows 7 PC with its locale set to United States. I have a unicode CSV (comma separated values) file that contains normal English text and Russian text.

In MS Word the Russian displays in Cyrillic, as it should. So I know I have that font on my PC. (Adobe Photoshop's text tool and various browsers on the same PC also display Russian in Cyrillic, confirming that my PC possesses the correct font.)

But in Excel and in Notepad the Russian just displays in some nameless gobbledy-gook. How do I get those programs to display in Cyrillic? Both apps have font settings but no font that I've found seems be to Cyrillic. Notepad even has an extended "Show More Fonts" option which shows me 216 fonts, including numerous Chinese, Korean, Japanese, Arabic, Hebrew, and south Asian fonts but I see no Cyrillic, even though the Show More Fonts dialog box has a Cyrillic option in its "script" dropdown. But the fact that Word, Firefox and Photoshop can display Cyrillic suggests that my PC has it.

NB - I don't want to set my entire PC to a Russian locale because it would be unusable to me in that state.

1
  • 1
    I doubt this is a font problem. Most US locale fonts cover the common Cyrillic fonts. Notepad is a very simple program with few options. If you open a file with the open file dialog you need to select the encoding, either Unicode, Unicode big endian, or UTF-8. If you open Notepad with a file association it will automatically detect the encoding, if it is able. If the file is not Unicode but using a Russian codepage you would have to convert it with a utility.
    – LMiller7
    Jun 6, 2017 at 3:11

2 Answers 2

1

As for notepad... use notepad++ instead..

As for excel.. don't use arial.. use the same font you use in Ms Word.

You may try noto font too..

1
  • Notepad++ worked...Obvious to most people, but make sure to check the "Localization Files" checkbox option (it might be called something a little different) during installation
    – velkoon
    Nov 23, 2022 at 5:14
1

This is not a font issue. If it were, you'd see blank squares like this: 🫠🫢🫣 (these are emojis new to unicode 14.0, and are unlikely to be displayable in the near future).

So, the problem is encoding - Notepad and Excel don't correctly understand your "unicode CSV". Excel requires a BOM (Byte Order Mark) to correctly view unicode files (both utf8 and utf16). In Notepad, try different encodings when opening the file - file => open => has Encoding selection in it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .