1

TL;DR: sfc does not run even in offline mode, Windows update can't install updates, dism reports no error, Windows is unable to do a reset. What can I do fix this problem?


I first noticed the problem when windows warned me that it could not install an update. I tried to run SFC but it returned the following:

Windows Resource Protection could not start the repair service.

I tried to start / restart trustedinstaller service with net start trustedinstaller but it was already running. Tried everything I could find to fix this problem but I could not find one solution that worked. Finally I tried to do a fresh install of windows by going to the advanced settings and reset, but neither the "keep my files" nor the "remove everything " worked as they failed to start saying that there was an error and no changes made.

I have even tried to use sfc offline from a bootable windows installer, but the error remain the same. DISM returns no error.

Is there anything I can do to fix this?

  • You shouldn't even use SFC on Windows 10, the fact that DISM returns no error, indicates to me, you have no system corruption. Which means SFC if it did run would report no errors as well. – Ramhound Jun 6 '17 at 17:22
  • @Ramhound Then what's going on that I can't even do a reset? I'm totally out of ideas – Victor Marcelino Jun 6 '17 at 18:51
  • 1
    Which Win10 build? 15063 has a bug, that requires deleting of 2 entries – magicandre1981 Jun 7 '17 at 14:52
0

The solution was to use a bootable windows installer (USB in my case) to do a format and install a clean version

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.