1

I need help whitelisting /dev/urandom to PHP's open_basedir setting for my particular setup without affecting the other sites on this server.

Editing the php.ini file will mess with others' sites on this box, right? I see people saying edit the vhosts file or the httpd file and there are tons of those, but not where they're "supposed" to be. I don't have a vhosts folder in /etc/www or have the directory etc/httpd either, for instance, but that's where people are generally directing others.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.1 LTS"

This below looks promising, except I have other sites to worry about (which is my fear about php.ini) and I am on Ubuntu:

Edit the file /etc/php5/cli/php.ini and comment out the open_basedir setting 
in this file. Debian uses different php.ini filesand a open_basedir in the 
php.ini for shell scripts makes not much sense. The open_basedir should only 
be set for the websites and thats what ispconfig is doing automatically,
even if its not defined in the global php.ini. 

from https://www.howtoforge.com/community/threads/ispconfig-update-open_basedir-restriction-and-dev-urandom-not-within.71393/

UPDATE

I tried the php.ini and it didn't even resolve the issue. Presumably it's a setting in ISPConfig, our hosting control panel

2
  • 1
    So as an FYI in case someone else comes looking for an answer, modifying the php.ini file to whitelist /dev/urandom didn't help anything. None of the config files (php.ini included) were calling for open_basedir so that leads me to the site manager, ISPConfig. I don't have total admin on it and the version I'm using, 3.0.x.x leaves that in server configuration. I got my boss to add /dev/urandom to the list and still no luck. I also switched the site to a diff PHP handler and no luck there either. I posted to an ISPConfig forum and am hoping for a reply. Jun 9 '17 at 21:19
  • Our resolution was to blow the box away and start again. Oh well Jul 19 '17 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.