6

I'm trying to create a GitHub page with Jekyll on Windows, but to do that I am told I need to install Bash on Ubuntu on Windows. Ok, fine, so I go to Bash's installation guide. My computer is 64 bit, Windows 10, build version 15063.296, which is above 14393, so I should have met the requirements.

However, when I follow the instructions, I can't find "Windows Subsystem for Linux (beta)" in Windows Features. What do I do?

Edit: Yes, I had Developer Mode enabled, even with it enabled it does not show up.

8

To install Windows Subsystem Linux, you have to enable Developer Mode in Settings App. So open Settings > Update & Security > For Developer > Developer Mode & select it to enable.

Developer Mode.png

Or you may enable Developer Mode with registry tweak. Make registry script (.reg) with the following::

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppModelUnlock]
"AllowAllTrustedApps"=dword:1
"AllowDevelopmentWithoutDevLicense"=dword:1

Then wait some time to download the developer package. Next, open the Control Panel, click “Programs”, and click “Turn Windows Features On or Off” under Programs and Features. Enable the “Windows Subsystem for Linux (Beta)” option in the list here and click “OK”. Alternatively install WSL with commands::

  1. Command Prompt:

    DISM.exe /Online /Enable-Feature /All /FeatureName:Microsoft-Windows-Subsystem-Linux /NoRestart
    
  2. Powershell:

    Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux
    

Then resrtart your system and you are good to go. From Windows 10 build 16215, it is no longer required to enable Developer Mode and beta tag was removed from WSL optional component. See Windows 10 Installation Guide for further details.

  • 1
    Yes, I've done that already as per the installation guide I linked in my original post, even with it enabled it still doesn't show up. (I should also mention, I did ensure that the developer package successfully downloaded as well) – a2xia Jun 8 '17 at 7:59
  • 1
    It worked with Powershell! Thank you very much! A followup question, if I may: when I'm running Bash now in Powershell there appears to be an encoding issue (the characters appear as boxes). I am running Windows 10 Home Chinese version which for some silly reason cannot have its OS language changed, is that the reason why Bash shows up strangely in Powershell? – a2xia Jun 8 '17 at 8:34
  • Interesting; my corporate Win10 laptop does have Developer Mode turned on, and the Registry settings are correct. But, Microsoft-Windows-Subsystem-Linux is not shown in the list of features that can be enabled. Is it possible that it was disabled by the brilliant minds that set up my corporate laptop? Or perhaps the developer package was not properly downloaded -- how to make it re-install? – Blisterpeanuts Apr 8 '18 at 16:53
  • This question was asked before 1709 was released, which means this answer as-is, is correct and does indeed answer the question. There are already newer questions which address newer builds of Windows 10. – Ramhound Apr 11 '18 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.