1

My Kali Linux will not boot to GUI. It only brings me to the terminal interface.

I've tried:

sudo apt-get update  
sudo apt-get upgrade  / and Sudo apt-get upgrade -y  

sudo apt-get install -f gdm3  

sudo apt-get install chkconfig  
sudo check config --level 2 gdm3  
gdm3  

sudo dpkg --configure -a  

None seems to work. I still can't boot into my Kali GUI.

What could I be missing? How can I make a recovery?

Thank you all in advance.

2
  • Can you boot with CLI? Did you uninstall desktop environment? – Biswapriyo Jun 8 '17 at 8:16
  • Yes I can boot with CLI, but I don't know anything about Uninstalling the Desktop Environment. Could you please suggest that in an answer, @Biswa? – Program-Me-Rev Jun 8 '17 at 8:31
3

So many possibiilties (please supply more detail if possible):

  • could be a software corruption issue as you've stated above. You could have installed which has possibly led to you breaking your system (check /var/log/dpkg.log)
  • could be a configuration file corruption issue in which case you'll need to flush or re-write part or all of your relevant configuration files to deal with it (look at apt-get in combination with purge option to deal with this)
  • could be a graphics driver problem. I remember in the past when I had to deal with Nvidia drivers I experienced something similar. Basically, when I upgraded the rest of the system the binary driver itself wouldn't work because it needed to be re-compiled to suit the updated circumstances
  • could be malware which is causing this problem. You never know
  • could be that you are someone else (without your knowledge and possibly even accidentally) screwed up a setting or configuration variable somewhere which has led to this
  • if you have an old version or backup image of your system or have some sort of snapshot system you could use this to roll back your system to your last known working configuration
  • I'd be going through the startup process and see where exactly things are dropping out. Namely, does it feel like it proceeds all the way like it used to or does it drop at the final few moments with X simply not working. That way you can narrow down which log files you should be consulting. For instance, /var/log/Xorg.0.log ones related to X, dmesg for ones related to the kernel, /var/log/dpkg.log for ones related to packaging, etc...

http://www.comptechdoc.org/os/linux/startupman/linux_suiglog.html

Can't login in Kali Linux

  • something else I'd be trying is to use the terminal interface to your advantage. Use the start, X, and gdm3 commands (and services) at the terminal and see if any errors show up. Depending on the error message you can make the necessary modifications to get your system back to normal
  • final choice is re-install from scratch obviously...
2

I know this is already answered aptly by @dtbnguyen, but I was able to realize that for me the issue occured due to absence of gnome which got deleted after I made a few updates.

So just in case, try re-installing gnome by:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install gnome

P.S. I did try the gdm3 method initially (which installs the display package manager for jessie distribution) but that just led me to a blank screen after login so after spending hours I had to return to the blank screen that I initially encountered by pressing the Ctrl + Alt + F1-F6 (any one of them, they lead you to the tty(1-6)'s) followed by the following command.

0

If the above answers were not working for you then i think when you are installing kali linux you should connect to internet (over wifi or ethernet) for me when i was installing kali 2020.1 in my pc most of the features of 202.1 versions were not showing up, at the select and install software section it was showing only some features then i had tried a lot of solutions but didnt work... then i installed kali having connected with internet and it worked. May be these sound silly but it worked, may be without internet connection it just installed the terminal mode (tty1)

0

From your terminal try going to

cd /etc/apt

Then do

sudo nano sources.list (or use any other text editor)

Add these lines at the end of file

deb http://http.kali.org/kali kali-rolling main non-free contrib

deb-src http://http.kali.org/kali kali-rolling main non-free contrib

Ctrl-o and ctrl-x to exit

To install gdm3

sudo apt-get install gdm3

Reboot and problem solved Thank you 😊 you can also watch a video : https://youtu.be/fLMoVNPpaQw

-1

What solved this for me was to log in as root from that terminal interface and issuing the command service gdm3 start .

-1

In my case I started GUI by logging in as root and then running

startx

Not the answer you're looking for? Browse other questions tagged or ask your own question.