0

I'm having a strange issue so I will try to explain as fully and succintly as possible.

OS: Windows 7 Professional 64-bit

I have a cloned image of a PC. (GPT Partitioned disk, Made using Ghost) I have created a disk from that image, and installed it into an identical machine.

I was getting an error saying:

Boot Device Not found (3F0)

So through googling and trial and error I discovered that the partitions had been re-named after cloning. I then discovered that I could delete some registry keys on the imaged machine to prevent the image having different drive letters, then replace them after imaging. I remade the image, but still the drive letters were incorrect.

I plugged the Cloned HDD into another sacrificial machine, and manually changed the drive lettering on the cloned HDD using disk management and DISKPART. Also using BCDEDIT.

Still this didn't work.

I have now created a bootable USB with a Windows 7 64-bit system repair ISO.

I ran the following commands via the repair disk command line:

bootrec /FixBoot
bootrec /FixMBR
bootrec /rebuildBCD
bootrec /ScanOS

The OS Scan discovered one Windows installation, although this was on disk E: which is strange since i had renamed the HDD to C: It seems the USB has taken that drive letter upon insertion.

So I restarted the machine, and lo and behold, the hdd boots perfectly, all software etc. is there. Great!

I then remove the USB and restart the machine to test. I am then greeted by the familiar error:

Boot device not found 3F0

I re insert the USB and restart. The machine immediately boots into the windows installation on the cloned HDD.

Am I somehow creating the boot records on this usb instead of my hdd? How do i go about changing where the bootrec goes?

(I have tried to run bootrec after running cd /d E:, Which is where the repair USB places my files, but this didn't work)

1

First and foremost, I always recommend utilizing the native imaging tools included in Windows, not 3rd party programs like Ghost, Acronis, etc. Windows <7 utilizes ImageX, Windows >8 utilizes DISM to capture an ESD (Windows partition only) or a WIM (any partition), as doing so prevents many of the problems users experience, as it's not disk/partition dependent.

Your issue is caused by Windows 7, as Windows 7 does not allow for the boot volume to reside on a GPT partitioned disk.

  • > Your issue is caused by Windows 7, as Windows 7 does not allow for the boot volume to reside on a GPT partitioned disk See I thought this also, but the native machine is GPT Partitioned – Thom G Jun 9 '17 at 6:59
  • That's how Windows 7 has always operated... Is the PC that was imaged running Windows 7 in a VM (for example via VMware Workstation)? If it's not, the only other way it could be running Windows 7 with the system partition on a disk with a GPT partition table is if the Boot Volume is placed on a separate HDD with MBR (via a secondary HDD, helper SSD/USB drive that has an MBR partition table and with the boot volume for Windows 7 on residing on it). The boot volume is not the OS partition, but the 300 - 512MByte partition before the OS partition. – JW0914 Jun 10 '17 at 1:14
-1

Use a windows 7 dvd to boot on and never plug the usb. After dvd boot it will wait to stary windows installation.

Select system repair on the left bottom side of installation screen then select boot repair / startup recovery option.

This can fix this issue

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.