0

I want to use Qt + Android. I installed Qt 5.9, added Android to installation, and installed Android Studio, SDK for android 22 and 25, NDK 15, apache ant and added some libs to system also.

However I can not run any project and I think it's because android emulator is not starting...

So I tried to launch emulator from terminal and I get this:

...
emulator: Starting QEMU main loop
emulator: registered 'boot-properties' qemud service
emulator: Adding boot property: 'qemu.sf.fake_camera' = 'front'
emulator: Initializing hardware OpenGLES emulation support
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  33
  Current serial number in output stream:  34
QObject::~QObject: Timers cannot be stopped from another thread

I read in some forums that I can do something like:

ln -sf /usr/lib/libstdc++.so.6  tools/lib64/libstdc++/libstdc++.so.6

but I do not have lib64 folder...

Do I need to install any other lib or what?

Thanks in advance!

1
  • Is the above comment your answer? If you added some detail (like what the problem was, any links where you found the answer) you could post it as an answer – Xen2050 Jun 9 '17 at 10:07
1

I did this to start emulator and worked:

"Open the config.ini file and change the respective line to: hw.gpu.mode=guest"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.