1

I can't connect to the guest machine from the host. Everything was working fine until my PC got Creators Update.

My setup:

  • VirtualBox 5.1.22
  • Host Windows 10
  • Guest Centos 7

The Host-Only network is configured on the host machine

Ethernet adapter VirtualBox Host-Only Network #2:

Connection-specific DNS Suffix  . :
Link-local IPv6 Address . . . . . : fe80::183b:f81b:7b2e:5e61%18
IPv4 Address. . . . . . . . . . . : 192.168.56.101
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Guest:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 08:00:27:a0:03:e2 brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.4/24 brd 10.0.2.255 scope global dynamic enp0s3
       valid_lft 1122sec preferred_lft 1122sec
    inet6 fe80::bad8:ceda:69cd:e25e/64 scope link 
       valid_lft forever preferred_lft forever
3: enp0s8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 08:00:27:8f:67:3b brd ff:ff:ff:ff:ff:ff
    inet 192.168.56.101/24 brd 192.168.56.255 scope global dynamic enp0s8
       valid_lft 731sec preferred_lft 731sec
    inet6 fe80::55b5:dc8b:786b:bcd3/64 scope link 
       valid_lft forever preferred_lft forever

I can ping the guest machine, but when I'm trying to access webserver or ssh I'm getting "Connection refused" error.

ssh root@192.168.56.101
ssh: connect to host 192.168.56.101 port 22: Connection refused

Firewall is disabled.

Any ideas?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.