Customize settings for Windows Firewall with Block all incoming connections, including those in the list of allowed apps

Transmit from the Windows system some IPv6 packets

ping -t -6 www.google.com    *(or your router even)*

Notice that the packets get dropped.

Now, disable the Windows Firewall and you get responses.

A bug in Microsoft Windows 7 & 10 code it would appear.

Using IPv4 everything works fine.

Anyone else seen this too?

  • Maybe I'm missing something, but firewalls (including Windows Firewall) often block ping packets. It's been happening since XP. You have to add an exception for the IP address of the machine you are ping to, or from. Jun 10, 2017 at 4:29
  • 1
    I can ping from the Windows system to IPv4 destinations just fine. It is a stateful firewall, but for IPv6 it appears that there are bugs in the firewall state table.
    – Leo Smith
    Jun 12, 2017 at 1:59
  • Ah, now I understand. Well, that is strange... in that case, I'm not sure what the answer is. Apologies. It would be a good idea to add that additional information to your original post, for clarification. Note that comments can be deleted at any time, and are not a good place to store information. Jun 12, 2017 at 2:01
  • I know this is already more than five years ago, but that setting seems to actually block the Router Advertisement packets, and somehow interferes with configuring a default route on my machine, sometimes. Mar 19 at 1:58


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.