2

My screen are darkening every 20 or some minutes. It was originally xscreensaver installed, but nothing changed after I removed it. This behavior very annoying when I am trying to see some movie.

There is output of xset q:

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled

I have tried to disable DMPS by xset -dpms but it looks like something reenables it time-to-time.

2

Solved by usage of XFCE's power managment GUI configurator

| improve this answer | |
1

Have a look at the output of xset q, it will tell you if DPMS is enabled, and the times to suspend.

You switch it off completely with xset -dpms, or set the times with `

xset dpms <standby_seconds> <suspend_seconds> <off_seconds>

You can also configure it in the ServerFlags section in your xorg.conf, see man xorg.conf.

Many player applications (e.g. mplayer) automatically disable dpms it while playing a movie.

| improve this answer | |
  • It doesn't help. Nor disabling DPMS, nor settings in VLC player. – ephemerr Jul 17 '17 at 7:00
  • Please edit question with output of xset q, the parts in Screen Saver and in DPMS. – dirkt Jul 17 '17 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.