0

Im running docker on my server and have started an apache2 container which acts as a reverse proxy for all incoming requests.

Now i have started an onlyoffice docker container on my docker. i have configured the onlyoffice instance, to use https and have added some self-signed certs.

If i access the server with https://serverip:onlyofficeport everything works as expected.

Now i would like to proxy the requests from the outside through my reverse proxy to the onlyoffice container.

This is my actual config:

<VirtualHost *:443>

        SSLEngine on
        SSLProxyEngine on

        SSLProtocol all -SSLv2
        SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM


        SSLCertificateFile      /etc/letsencrypt/live/defg.com/fullcha$
        SSLCertificateChainFile /etc/letsencrypt/live/defg.com/fullcha$
        SSLCertificateKeyFile   /etc/letsencrypt/live/defg.com/privkey$

        ServerAdmin webmaster@defg.com

        SSLProxyVerify none
        SSLProxyCheckPeerCN off
        SSLProxyCheckPeerName off
        SSLProxyCheckPeerExpire off

        ProxyPreserveHost on
        ProxyPass "/" "https://172.17.0.12:444/" retry=0
        ProxyPassReverse "/" "https://172.17.0.12:444/"

        ServerName abcd.defg.com

</VirtualHost>

Unfortunately, this does not work. I get the following errors:

[Sun Jun 11 07:26:26.569140 2017] [proxy:error] [pid 60] (111)Connection refused: AH00957: HTTPS: attempt to connect to 172.17.0.12:444 (172.17.0.12) failed
[Sun Jun 11 07:26:26.569187 2017] [proxy:error] [pid 60] AH00959: ap_proxy_connect_backend disabling worker for (172.17.0.12) for 0s
[Sun Jun 11 07:26:26.569197 2017] [proxy_http:error] [pid 60] [client 192.168.30.24:64712] AH01114: HTTP: failed to make connection to backend: 172.17.0.12

It seems that apache cannot connect to the onlyoffice instance. On the webpage it shows me "503, Service unavailable"

I have tried everything i can imagine. Now i hope that someone can help me.

Thanks Regards

  • You might want to look into linked containers. This is ultimately what you need to do this without exposing other containers’ ports. It will also give you named access, so changes in the containers’ IP addresses won’t matter. – Daniel B Jun 11 '17 at 10:27
0

Problem is solved. I had to use the IP Address of the Server itself instead of the docker container IP-Address. This is strange, since i usually use the IP Address of the Docker Container.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.