The locale of boot menu can be checked with bcdedit, how to change the locale attribute?


Windows Boot Manager
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  zh-CN
inherit                 {globalsettings}
default                 {current}
resumeobject            {82ae1d6d-4c6a-11e7-bbe7-484d7ecdb30c}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
identifier              {current}
device                  partition=C:
path                    \WINDOWS\system32\winload.efi
description             Windows 10
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {82b54566-4c6a-11e7-bbe7-484d7ecdb30c}
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \WINDOWS
resumeobject            {82ae1d6d-4c6a-11e7-bbe7-484d7ecdb30c}
nx                      OptIn
bootmenupolicy          Standard

bcdedit /set {bootmgr} locale en-US

| improve this answer | |

In my case the C:\ system partition was set to en-GB; I tried the command line above and it didn't reset the C:\ partition. I had to modify it to this: bcdedit /set {current} locale en-US, and then my locale changed on my C:\ partition. I kept getting the British spelling of Centre every time it appeared in my menus or commands/options, e.g. Network and Settings Centre.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.