0

I am fed up with the default Windows interface so I decided to install Cygwin and run a gnome shell on startup.

When the installation was done, I went into Cygwin and started X with this command xinit gnome-session and I got this error and the shell closed shortly thereafter.

Screenshot of gnome error

and this is the output log

Screenshot of output log

I think it has something to do with display drivers but I really don't know when I was installing Cygwin it came up with an error but stupidly I pressed OK without reading it, so help.

  • 4
    For textual output, copying the text is far more beneficial for us than screenshots. – choroba Jun 12 '17 at 9:50
  • $ xinit gnome-session Welcome to the XWin X Server Vendor: The Cygwin/X Project Release: 1.19.2.0 OS: CYGWIN_NT-10.0 2016-MP06NE55 2.8.0(0.309/5/3) 2017-04-01 20:47 x86_64 OS: Windows 10 [Windows NT 10.0 build 14393] (Win64) Package: version 1.19.2-1 built 2017-03-09 XWin was started with the following command line: X :0 (II) xorg.conf is not supported (II) See x.cygwin.com/docs/faq/cygwin-x-faq.html for more information LoadPreferences: /home/RYC0001/.XWinrc not found – Fish4203 Jun 12 '17 at 20:18
  • LoadPreferences: Loading /etc/X11/system.XWinrc LoadPreferences: Done parsing the configuration file... winDetectSupportedEngines - RemoteSession: no winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL – Fish4203 Jun 12 '17 at 20:18
  • winDetectSupportedEngines - Returning, supported engines 00000005 winSetEngine - Using Shadow DirectDraw NonLocking winScreenInit - Using Windows display depth of 32 bits per pixel winWindowProc - WM_SIZE - new client area w: 1902 h: 983 winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff MIT-SHM extension disabled due to lack of kernel support – Fish4203 Jun 12 '17 at 20:19
0

Message

libGL error: Screen is not Windows-DRI capable

indicates that we wanted to use direct, hardware-accelerated OpenGL ('Windows-DRI'), but that the server didn't allow it.

This could be due to:

  • server option -nowgl
  • windowing mode doesn't permit wgl (i.e. not -multiwindow)
  • display driver does not support WGL (i.e. the default VGA driver)

etc.

More info.

Try run with -multiwindow:

xinit gnome-session -- -multiwindow
|improve this answer|||||
  • it just does the same thing except in a smaller window – Fish4203 Jun 12 '17 at 20:25
  • Try with -nowgl: xinit gnome-session -- -multiwindow -nowgl – Tomasz Jakub Rup Jun 12 '17 at 20:27
  • still, doesn't work I can boot into Xorg – Fish4203 Jun 13 '17 at 0:40
  • this is the error i get when i run gnome-session from within x $ gnome-session gnome-session-binary: PID 11044: WARNING: Using null backend for session tracking Unable to init server: Could not connect to 127.0.0.1: Connection refused – Fish4203 Jun 13 '17 at 0:47
0

To run the the Xserver with the window manager in cygwin use:

startxwin

and if you need to disable the WGL accelerator

startxwin -- -nowgl

See https://x.cygwin.com/docs/ug/using.html#using-starting for details.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.