3

If I type "dir" into a console command line I see the following behaviour:

  1. I type "d" and nothing appears in the console (I expect to see "d" immediately following the prompt)
  2. I then type "i" and the "d" appears on the command line immediately following the prompt (I expect to see "di")
  3. I then type "r" and the "i" appears on the command line immediately following the "d" showing "di" (I expect to see "dir")
  4. I press return and see a directory listing as expected.

How can I stop the display lagging one character behind the keyboard?

This occurs when cmd.exe or a bash session (and presumably any other console app which takes keyboard input) when remoting into a surface pro 4 /Windows 10 from an IMAC running latest MACOS and from a Windows 10 client under parallels and from an IPAD using the Microsoft RDP client. I assume I would see the same problem from any client. All software is up-to-date as of 12-June-2017

The behaviour occurs most of the time but there have been occasions when the problem went away for no dicernible reason.

A partial workaround is to "Use legacy console" available from the console->Properties menu with a big font. This works for cmd.exe but unfortunately the bash shell won't run in this mode.

  • Ping the server from your client constantly: ping -t server and tell me if there is a difference. – davidbaumann May 6 '18 at 7:00
  • superuser.com/questions/1137697/… There is no solution, too. – davidbaumann May 6 '18 at 7:01
  • Did you check pinging? Can you connect the surface it via wired ethernet? – davidbaumann May 8 '18 at 6:02
  • This issue was addressed in a subsequent question which got answers superuser.com/questions/1137697/… – mikemay May 8 '18 at 6:07
  • @davidbaumann. Thanks for your help. Your pinging approach looks as if it is consistent with the answers to superuser.com/questions/1137697/… – mikemay May 8 '18 at 6:09
3
+50

I have the same issue. Oddly, the issue goes away when the remote computer's monitor is on, even if it is showing the lock screen and not logged in. As soon as the remote computer's monitor sleeps, the problem comes back.

Try to see if that is the same for you. My work around is to never let the monitor sleep. I just kill the power to it, and let Windows send display signals to turned off monitor.

  • Thanks for contributing. In my case the "server" of the remote session is the Surface Pro and the "client" is an IMac or IPad. There is no question of killing the power to the "server's" monitor. It sounds as if your configuration is significantly different. – mikemay May 6 '18 at 6:50
0

The best workaround is described in Remote desktop develops mouse/keyboard lag after some duration and entails preventing the screen of the remote "server" (Surface Pro 4) to turn off. See the other answer for the required Windows 10 settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.