1

I've seen loads of questions and answers from people wanting to switch auto-mapping off from shared mailboxes but I seem to have exactly the opposite problem.

I'm trialling Office 365 Business Premium for the company I work for and I've managed to get through everything so far without a hitch. I've set up users, the DNS records are all in place for all the Office 365 services, everything seems great. I've added users, I've added shared mailboxes, I've granted permissions to users on those shared mailboxes.

Now, according to this Office 365 article,

The shared mailbox is automatically available in the Folder pane in Outlook.

The only problem is... it isn't.

It can't be a permissions problem because if I access the OWA I can access the mailboxes using the given steps. I can also manually add the mailbox to Outlook by going the File -> Open -> Other User's Mailbox way.

So why does it not automatically map in Outlook (I'm trying in Outlook 2016 for Mac) and how can I get it to? There are quite a few users that will be using a number of shared mailboxes, I don't want to have to go around and manually add the mailboxes for each one.

  • 1
    You mentioned that you're trialing O365, so I'm guessing you're in a hybrid setup right now. You're most likely caused by the issue mentioned here. These issues can occur when the shared mailbox is created by using the Exchange Online management tools. In this situation, the on-premises Exchange environment has no object to reference for the shared mailbox. Therefore, all queries for that SMTP address fail. – shinjijai Jun 12 '17 at 13:43
  • Thanks @shinjijai but we actually haven't used any Exchange software before so it's a pure cloud solution, no hybrid. – Stuart H Jun 12 '17 at 13:58
2

Outlook for Mac does not support Auto-mapping. We need to open the share mailbox/folder in Outlook for Mac clients manually.

Besides, in Outlook 2007 and later Outlook for Windows, Autodiscover automatically maps to any mailbox for which a user has full access permissions. You can have a try with the Office clients for Windows. If other users are using Outlook for Windows, don't worry that they would see the auto-mapped shared mailbox in their Outlook profiles.

  • D'oh! Since I would be deploying Office 365 in a predominantly Windows environment (in fact, I'm the only Mac user) I guess I should have tested on a Windows machine. Just done a test now and the auto-mapping does indeed work. I just wish that article stated that! Thanks for this! – Stuart H Jun 13 '17 at 7:43
-1

I just had the issue where shared mailbox will not show up in outlook. Upon checking the settings in Office 365 admin portal (Activ Users/Mail Settings/Email Apps) the MAPI and IMAP settings were disabled. After enabling, and restarting the outlook few times, shared folder became available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.