6

I've been looking for a solution to this, but I cannot seem to find anyone who has solved it (or even have the exact same problem).

My problem is that "Show black screen" option when connecting to a client doesn't work. "Disable remote imput" works, though. But the remote screen simply doesn't go blank.

I tried enabling the "Enable black screen option in the settings on the teamviewer "server", but when I did that the client couldn't even connect - it got stuck on "Initializing display parameters" forever.

Since I'm trying the free version of TW before buying, there also is absolutey no help to get from the TW team.

Anyone got any suggestions?

I've installed and reinstalled the TW monitor drivers on both the local and the remote computer, but it doesn't even seem to ATTEMPT to black the remote screen.

UPDATE: When connecting from Computer1 to Computer2, it doesn't work (as described above). However, when connecting from Computer2 to Computer1, it works.

So the problem seems to be with TW and the display drivers on Computer1.

  • Have you installed the monitor driver? Can be done from teamviewer settings->advanced if my memory serves me correctly. – LPChip Jun 13 '17 at 9:56
  • Yup. That happened automatically when I first checked the "disable remote input" and "enable black screen" options on the client. – Hfrav Jun 13 '17 at 10:45
  • I've also reinstalled the tw monitor drivers on both the machines (remote and local). – Hfrav Jun 13 '17 at 11:42
  • dumb question, did you reboot? – LPChip Jun 13 '17 at 12:51
  • You mean after reinstalling the TW monitor drivers? – Hfrav Jun 13 '17 at 14:06
3
Here are the details of the NVidia driver issue.
NVidia driver version and will black screen work...
368.69 - OK
375.70 - OK
376.09 - OK
378.92 - OK (3-20-17)
--------------------------------- Breaks here
381.65 - NO (4-06-17)
381.89 - NO
384.76 - NO
385.28 - NO

As of 5/10/2018 - (over 1 year!) The issue is still not fixed.
2

I have it finally working on my computer. The issue is pretty simple and a complete embarrassment or lack of technical skills on TeamViewer's point. The driver is not "digitally signed" with a correct date so Windows rejects it. If you go into your BIOS and allow drivers once to be approved without signature then the TeamViewer black screen works correctly. Just search in google for

"Windows cannot verify the digital signature for this file" error

There are plenty of links on how to fix this and you don't have to make it permanently accept all unverified digital signatures. Just this accept it this once.

Again this 100% TeamViewers lack of professionalism by having a simple low level driver not digitally signed and approved. Hope this helps

1

No one has an answer to this. This is no wonder, since TeamViewer themselves has verified this as a known issue/bug. With no scheduled fix, of course.

The problem is with the NVIDIA drivers. Some further research seems to suggest that the problem occurs in the latest handfull of versions. I've not got the details of that, and I don't find it very relevant as TW doesn't seem to prioritize the issue.

  • >> TeamViewer themselves has verified this << Could you please provide a link? Thank you. – Alexander Gonchiy Sep 25 '17 at 9:21
  • I got it by mail from their support team. There's also a thread about it in their support forums. – Hfrav Sep 26 '17 at 8:20
  • This one? – Alexander Gonchiy Sep 26 '17 at 15:09
  • Yup. That's the one where I answer my own question, referring to the answer I got from TW. – Hfrav Oct 9 '17 at 13:40
0

I had the problem that I was getting stuck at "Initializing display parameters". Try unchecking "Remove remote wallpaper" from Options > Remote Control.

https://i.stack.imgur.com/l4wut.png

0

It has been suggested not to install the TeamViewer monitor drivers. Maybe that helps?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.