1

My PC is a Toshiba satellite L55 with an Intel core i5 running windows 10, and the maximum clock speed is 2.4GHz. It has been running good and the clock speed used to increase with the usage percentage, but now the clock speed is constant (mostly at 2.74GHz) but the usage percentage lowers and increases depending on what I am doing. I tried booting it in safe mood but no change at all, and it's running on a SSD if that's important.

4
  • Need more info like what O/S you are using, and what the process monitor says is using up your CPU most, for starters. Welcome to Superuser. Please be sure to take the tour at superuser.com/Tour to get the most out of this site.
    – SDsolar
    Jun 13, 2017 at 16:35
  • 1
    The frequency of a CPU has very little do with the load the CPU is under normally. There a reason you are not happy with your CPU running at a faster more efficient frequency?
    – Ramhound
    Jun 13, 2017 at 16:35
  • i just like running on defaults Jun 13, 2017 at 16:39
  • Have you changed the Windows power profile from "Balanced" to "High performance" as this would be one scenario where the CPU would be forced to run at constant full speed...? I've no idea if "Safe Mode" loads power profiles, however...
    – Kinnectus
    Jun 13, 2017 at 16:41

3 Answers 3

5

The path might be slightly off since i'm doing this via a win8.1 device, but the idea stays the same:

Go to Control Panel > All Control Panel Items > Power Options and click on Change plan settings for your current power plan.

Click on Change advanced power settings and go to the Processor power management. In there you can have a look at the Minimum processor state setting.

4
  • Then would you mind marking the answer as accepted so other people with this issue can find an easy solution? Jun 14, 2017 at 6:12
  • 1
    I've changed this setting, with Minimum processor state = 5% at balanced but the CPU still run with high frequency. It only decreases when I choose Power save mode.
    – ThanhLD
    Mar 21, 2019 at 1:49
  • Finally, I was found the error, caused by the windows available in SSD, previous this windows I used for my laptop, I think something setting not works when I used for PC, so problem solved after I reinstall windows.
    – ThanhLD
    Mar 22, 2019 at 2:08
  • This answer solved my issue. Before the change, my CPU speed displayed in task manager is fixed at 3.45GHz (much higher than maximum speed 2.90 GHz). I switch the power plan to Balanced and adjusts maximum processor state to 85% and then the CPU speed decreases and becomes dynamic.
    – er.Zhu
    Jan 29, 2021 at 16:35
0

On Windows 10, clicking the battery icon in the taskbar and changing the slider on there to anything other than high performance fixed it for me. Turns out just changing the power plan settings is not enough. Screenshot

0

Uninstall any utility software that came with the device, any "Control Center", "Smart Tool", or anything like this. The OS will always manage this better.

Many tools try to override the OS settings, but the the OS will always reset this. Such tools can make your CPU clock quickly jumping between 2 and 4 GHZ while idling.

After 20 years I can only conclude, that if the tool includes "Smart" in its name - it is always the opposite. :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .