1

I have two machines at work running Windows 10. From one, I can connect to the c$ administrative share, but trying to connect from the other to the first computer's c$ share fails.

I have read about the workaround for adding a registry key to enable access to administrative shares, but it seems hackish. And the first computer whose admin share I can access has no such registry key.

Is there some Windows setting I am missing to enable access to administrative shares?

  • What you call a workaround, is not a workaround. It is the only solution. If the Registry key is absent, you have to create it. But also, it drastically diminishes security of the affected computer. Clearly, you've found the solution; you just don't like it. – user477799 Jun 3 '18 at 10:05
  • @FleetCommand I agree. I don't like it. But it is not the only solution. See the answer I submitted for my own question below. – Baodad Jun 4 '18 at 20:10
  • LOL. See the comment I submitted for your answer. – user477799 Jun 4 '18 at 22:40
  • 1
    Additional info on my blog as well - including installing the required services – Canadian Luke Jun 8 '18 at 18:36
1

On the computer you are having trouble connecting to, search for the Windows setting for: "Manage Advanced Sharing Settings" and make sure that "Turn on file and printer sharing" is selected for your Domain network.

Turn on file and printer sharing

Doing this will automatically enable the necessary Windows firewall rules to enable file sharing and also ping/ICMP responses.

Or, if you like, you can enable the following firewall rules yourself, as shown below. These must be configured on the computer you want to access, not the computer attempting to gain access. Specific rules in Windows Advanced Firewall configuration

  • Did you even try this yourself? It does not work. – user477799 Jun 3 '18 at 10:03
  • 1
    @FleetCommand Yes. This worked for me in my environment. That is why I documented it here. I thought it might be helpful to someone with a similar issue. – Baodad Jun 5 '18 at 22:29
  • Try reproducing it on a pristine virtual machine then. You will discover that it does not work. – user477799 Jun 6 '18 at 10:36
  • Well. I see this answer has received upvotes. (Not just the answer; also, the question, the answer and your comment.) That's odd, because this answer isn't just wrong; it is blatant nonsense. I can tell that because I know what Windows Firewall and Windows sharing settings do. – user477799 Jun 8 '18 at 18:29

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.