0

I have split a large audio file into many smaller audio files.

However; the many audio files seem to have a total size that is about half the size of the original file (!!!), why is this?! It happens to .webm, .ogg, .mp3, and possibly others.

Also is this the right place for such a question?

5
  • 2
    What is the fileformat of the file you start with? is it also a compressed format, or is it .wav? If compressed what format is it in and what compression settings were used? Does your output match that?
    – LPChip
    Jun 14 '17 at 18:34
  • @LPChip I've tried three different files that were .ogg, .webm, and .mp3. I did not re-encode anything, just -c:a copy from same fileformat to same fileformat.
    – ZN13
    Jun 14 '17 at 18:56
  • Your question is unclear. Please post the exact numbers, and show what exactly you did do to split the files. Thanks!
    – slhck
    Jun 16 '17 at 7:07
  • @slhck nah sorry, not gonna clarify cause I messed up, disregard this question. Asked moderator to delete the question because it's a waste of space but they declined.
    – ZN13
    Jun 16 '17 at 7:18
  • What was the problem? You could also quickly ask on Super User Chat or Meta Super User to have it deleted, but I guess if there's an answer that got upvotes a mod is less likely to delete the question.
    – slhck
    Jun 16 '17 at 12:33
3

Check the bitrate of files with Mediainfo. If it's the same, check the duration. If it's the same, it's probably tags of the original file, could be embedded image(s) for example, that make original bigger. Those can be checked with Mp3Tag.

Also maybe try something other than FFmpeg.

1
  • 1
    "maybe try something other than FFmpeg" – how would that help, specifically? What should another program do differently?
    – slhck
    Jun 16 '17 at 7:08
1

That depends on how you split them. Could be, that you're not only cutting the files, but also re-encoding them to mp3s with smaller bitrate.

2
  • I specifically am not encoding, I'm just copying. Like this: ffmpeg -i input.ext -c:a copy -ss start_time -t end_time output-ext and then I do that multiple times with different start time and end time depending on how many splits I want (always the whole file into many smaller files).
    – ZN13
    Jun 14 '17 at 18:55
  • 4
    just to be sure: you know that -t (specifying a duration) is different from -to (specifying the end-point)? see trac.ffmpeg.org/wiki/Seeking can't reproduce the behavior with any mentioned setting.
    – flolilo
    Jun 14 '17 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.