26

Is there a way of pointing to the proper Java/JRE in dbeaver.ini?

This works:

dbeaver.exe -vm "C:\Program Files\Java\jre1.8.0_131\bin\server"

...but this way I can't pin DBeaver to taskbar (its icon gets duplicated)

Is there a way of achieving the above within the ini file? Or does the JRE need to be determined before dbeaver.ini file is read?

(I would like to stick to DBeaver without installing its bundled JRE.)

These are -vm args I tested as #1 line of dbeaver.ini:

-vm "C:\Program Files\Java\jre1.8.0_131\bin"
-vm "C:\Program Files\Java\jre1.8.0_131\bin\javaw.exe"
-vm "C:\Program Files\Java\jre1.8.0_131\bin\server"
-vm "C:\Program Files\Java\jre1.8.0_131\bin\server\jvm.dll"

6 Answers 6

31

Edit:

Specify the -vm argument after the -startup and -launcher.library arguments but before -vmargs. Additionally the path to the JRE should be on the line after -vm without the path quoted, e.g.

-startup
plugins/org.eclipse.equinox.launcher_1.3.201.v20161025-1711.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.401.v20161122-1740
-showsplash
-vm 
C:\Program Files\Java\jre1.8.0_121\bin\server\jvm.dll
-vmargs
-Xms64m
-Xmx1024m

How did you install DBeaver? From the downloads page:

If you already have JRE installed on your computer you may disable JRE option in installer. However it is recommended to use JRE shipped with DBeaver (it won’t be break any existing JRE installation, nothing will be copied in system folders, registry or environment variables).

Did you disable the JRE option when installing?

9
  • Yes sir, I have disabled/unchecked installation of DBeaver's JRE. And I would like to point DBeaver to one of the JREs I have on my machine. Jun 15, 2017 at 12:05
  • 1
    @JaroslavZáruba Have you added -vm "C:\Program Files\Java\jre1.8.0_131\bin\server\javaw.exe" to your dbeaver.ini BEFORE -vmargs?
    – Kyle
    Jun 15, 2017 at 13:08
  • javaw.exe is not under server\ (checked all JDKs/JREs under C:\Program Files\Java)... but I have updated the question with list of -vm I tested Jun 16, 2017 at 7:53
  • Regardless of what I put into the -vm arg I see following on the 3rd line of the error report: "java.version=1.7.0_55" Jun 16, 2017 at 8:13
  • 1
    @JaroslavZáruba, I've updated my answer to show an example .ini. I tested with a fresh install of DBeaver on Win 7 without JRE and pointed it to an existing JRE with success this way.
    – Kyle
    Jun 16, 2017 at 14:04
9

This is my solution for Linux users. Dbeaver configuration file is located in the following folder:

/usr/share/dbeaver/dbeaver.ini

Edit dbeaver.ini by adding these lines at the top of the file:

--launcher.appendVmargs
-vm
/home/xxx/java/jdk1.8.0_221/jre/bin
7

For Arch/Manjaro users ...

sudo pacman -S jre-openjdk
archlinux-java status

The answer could be something like ...

Available Java environments:
  java-15-openjdk
  java-8-openjdk (default) 

Then you need to change the default environment with:

sudo archlinux-java set java-15-openjdk

That's it!

1

Running Windows 10, all I did was open up the dbeaver.ini file in the install directory and write these couple of lines on top of everything.

-vm
C:\PathToJDKInstallationDirectory\Java\jdk-11\bin\server\jvm.dll

So now the file looks like this:

-vm
C:\Program Files\Java\jdk-11\bin\server\jvm.dll
-vmargs
-XX:+IgnoreUnrecognizedVMOptions
--add-modules=ALL-SYSTEM
--add-opens=java.base/java.nio=ALL-UNNAMED
--add-opens=java.base/java.net=ALL-UNNAMED
-Dosgi.requiredJavaVersion=11
-Xms64m
-Xmx1024m
-Ddbeaver.distribution.type=exe

Hit save and DBeaver is now working properly.

2
  • 1
    Nice to have a Win answer as well :-) It would be improved by showing the entire content of the .ini file instead of these two lines, as someone with isn't familiar with this file (take me, for example) wouldn't be able to do this correctly. You can just edit the answer and add it there. Mar 24, 2023 at 14:38
  • Works great with current last version (23.1.5). Thanks!
    – Camille
    Aug 22, 2023 at 7:42
0

On macOS, I was able to check the location of my JDK with this:

$ /usr/libexec/java_home -F

Then I could use that value to replace the -vm value in dbeaver.ini, which is within DBeaver.app:

$ nano /Applications/DBeaver.app/Contents/Eclipse/dbeaver.ini 
-1

I pinned the icon to the taskbar and then added the -vm parameter changing the properties of the icon. The icon got duplicated. I removed the first one and pinned and renamed the second.

1
  • Hello, I fail to understand how this is any related to the question, apart from the -vm parameter. Could you explain?
    – Destroy666
    May 2, 2023 at 21:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .