1

I’ve got several computers connected to a local network via a Fritz Box 7390 router. There is no Windows Domain, Workgroup, or Homegroup, they are all just on the same sub net.

This works well on all devices except one. One computer (Lenovo Thinkpad L540, Intel Dual Band Wireless-N 7260 Adapter, Windows 10, current patch level) cannot connect to any other local computer using WiFi. It works when connecting with an ethernet cable. Connections to the internet work fine all the time.

While connected with WiFi, trying to access a network share results in a “Windows cannot access \OtherComputerName” message. The troubleshooting wizards found the issue: “Windows can communicate with the name resolution server but can't find the host name.”.

A simple Ping to the host name resolves the correct IP Address, but each Request Timed Out. This is true for all local IP Addresses except the address of the router/gateway itself.

If this computer is rebooted or I reset the IP configuration using ipconfig /release followed by ipconfig /renew everything works fine for about 30 to 90 seconds and then reverts back to the “broken state”.

There are 3 other computers with Windows 10 connecting with Wifi without any problem.

What I tried so far…

  • Updated the driver of the Wireless Adapter to most recent version
  • Uninstalled all network adapters in Device Manager and let Windows reinstall them
  • Ran the network troubleshooting wizard. – No problem detected
  • Temporarily switched off Windows Firewall
  • Manually configured IPv4 settings instead of getting them by DHCP
  • Temporarily changed the connection from Private to Public in Windows Network and Sharing Center
  • I double checked that the router does not use any form of Wireless Isolation (Guest-Access-WiFi in Fritz Box router)

Nothing of the above made any difference to the problematic behavior.

On this PC there is just Windows Defender and Windows Firewall installed. No other security software.

What is causing this weird issue and how to fix it?

  • In the Network and Sharing Center, is the wireless network private or public? – CharlieRB Jun 15 '17 at 19:29
  • @CharlieRB: It is currently Private, but I temporarily switched to Public and it did not make any difference. – PhilS Jun 15 '17 at 19:46
  • What is your WiFi router make/model? Some routers are configured not to allow connected devices to "see" each other. See Wireless isolation – wysiwyg Jun 15 '17 at 20:13
  • @wysiwyg: It's a Fritz Box 7390. The no other computer on the network is affected by the issue. – PhilS Jun 15 '17 at 20:17
  • Regarding Wireless Isolation: AFAIK this is implemented in the Fritz Box router as "Guest-Access-WiFi". This feature is not enabled in my router. – PhilS Jun 15 '17 at 20:36
0
  1. Go to c:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking.
  2. Delete idstore.sst and move on to Step 3. If deleting idstore.sst doesn’t work, go back to c:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking and delete all files and folders in it and go back to Step 3.
  3. Go to the Network Settings and Leave the Homegroup.
  4. Repeat this for all the computers in your network.
  5. Turn off your computers.
  6. Turn on just one, and create a new Homegroup on it.
  7. This Homegroup should be recognized on all of your computers now.

another Solution:

Sometimes it can happen that services needed for Homegroup to work are disabled for some reason, but there’s a way to enable them.

  1. In the Search bar type services.msc and search the list for peer network grouping, peer network identity manager, homegroup listener and homegroup provider.

  2. If those services are disabled or set to manual set them to auto and leave your Homegroup.

  3. Create new Homegroup and see if it works. We have to mention that you might have to do this for all the computers in your network.

And another:

  1. Find: C:\Program Data\Microsoft\Crypto\RSA\MachineKeys

  2. And then find: C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking

  3. Right click each folder and choose Properties.

  4. Go to Security tab.
  5. You’ll see group of users, click on a group, and press Edit.
  6. From the list of options, click Full Control.
  7. Repeat the process for all that you wish to have access to your Homegroup.
  • I really appreciate your input but please pay attention to the fact that there is no Homegroup involved and it is neither desired nor is supported by all the devices to create one. – PhilS Jun 16 '17 at 8:49

protected by JakeGould Jul 28 '18 at 17:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.