My date and time is correct and my security software is not causing the problem as I have disabled it. My hosts file has nothing wrong with it.

I cannot access google.com

  • Start with this in case it's something simple: howtogeek.com/171924/… Reset Chrome and profile, etc. to defaults. Confirm you're running the latest version of Chrome too in case it's a version bug. – Pimp Juice IT Jun 16 '17 at 23:45
  • That's the wrong answer. It's not a Chrome issue, it's a Windows issue. Someone on Bleeping Computer gave me the correct answer. – desbest Jun 16 '17 at 23:52
  • 2
    Please post your answer... I only posted a comment to your question and not an answer. If you found the solution to your own problem, please write up the detail as an answer to help people that run into the same problem. Glad to hear you fixed your problem! – Pimp Juice IT Jun 16 '17 at 23:56
  • You can answer your own question.@desbest – DavidPostill Jun 17 '17 at 12:15
  • Also why would it be a chrome bug? If it was a chrome bug, then everyone in the world with google chrome wouldn't be able to access google. – desbest Jun 18 '17 at 17:08

After using a faulty hotspot, having a faulty wireless antenna or something else, something to do with the DNS was caching, so I changed my DNS servers to Google DNS then it worked. Now the cache had been cleared I could then revert to not using Google DNS.

Don't forget to restart Chrome after changing the DNS settings.


  • "so I changed my DNS servers to Google DNS then it worked"... So it was a network issue and not a Windows issue unlike what you said in a comment. This does not actually solve the problem explaining why the other DNS settings did not resolve websites with DNS names though? Did someone have their NIC TCP/IP DNS settings set improperly or something and that was the root cause? Otherwise you reach out to the [ISP] DNS admins of the DNS servers that are having issues to really fix the problem so this is a workaround you provided to the DNS problem you were having from your Windows machine. – Pimp Juice IT Jul 2 '17 at 5:12
  • I don't know what NIC TCP/IP DNS settings is. I just used the settings that was default with windows. I don't connect to the internet through a network. – desbest Jul 2 '17 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.