0

I just got a Aspire GX-781 desktop computer and one of the USB 3.0 ports (the one of the front) isn't working properly. I'm on Windows 10 Home, 64 bits and no matter what device I plug into the port, Windows won't recognize. I do not get any error message, nothing happens at all on Windows, it's as if I never plugged anything in. However the port does provide power to the devices I connect there.

Nothing catches my eye on Device Manager.

DM

All other USB ports seems to be working fine. Including the only other 3.0 port. I also tried to boot from a USB flash drive connected to the allegedly faulty port and it didn't work, it didn't even come up as an option in the boot menu.

All USB drivers seem to be up to date.

Any help?

0

What you are mentioning there sounds like a dead port to me. Your problem is a hardware issue rather than a driver one. Best not to use this port or you might damage your USB devices. There are tools out there to troubleshoot the USB port, however, since the computer is new I would take it back for replacement

  • It turns out I'm a retard. The port was disconnected, or rather connected in the wrong place in the motherboard. Acer is also to blame for not providing a user manual for the motherboard. Can't find it online either. Thanks. – Git Gud Jun 17 '17 at 11:31
  • I did not know you had built the computer yourself! At least you found it, we'll done – Genesis_GDK Jun 17 '17 at 11:34
  • I didn't. But I opened it in order to try and install one of my hard drives and in messing with the cables I disconnected one and reconnected it in the wrong place. – Git Gud Jun 17 '17 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.