0

I have a TurtleBeach headset that I usually use for my PS4. The mic works perfectly loud on PS4. When plugging it into my computer into the pink slot at the back of the computer it connects to pc, once its connected I try and record my voice, I have tried online, audacity, adobe audition and many other ways, I have even tried listening to the device via windows 10.

I am on windows 10, I think its a VIA headset or it said something like that in the device manager. The issue is its really quiet and you can't hear it at all.

When putting the boost up to 30 (max) you can hear it a little.

Volume is also max at 100 can anyone help?

I have tried so many things, restarting, taking out and in, trying other microphones, uninstalling and reinstalling the drivers, updating the drivers, so many but nothing works?

  • Ok you plugged it into the pink plug? But not also the green one? Pink is for the microphone, green is for headphones. Also, analog headphones do not show up in device manager. Are your headphones perhaps USB? These are important questions the answers to which change everything about how to fix your problem. Trying to piece together what you've said... it sounds like your headset uses USB for the headphones but still uses analog for the mic... kinda weird. – Cliff Armstrong Jul 15 '17 at 3:42
0

Right click on your Speaker icon in the lower right corner, near your clock. Right click, choose Playback Devices. Scroll down the list under the Playback tab to your Turtle Beaches and right click, choose Properties. Go to the Enhancements Tab and click the box that says Loudness Equalization. Careful, it may be loud as soon as you hit Apply

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.