1

A couple days ago I started a Windows 10 Reset to start fresh again. At this point I am stuck and not sure what to do next. I am using Ubuntu right now which is dual-booted on this machine.

Some background on devices and setup:

  1. Lenovo y510p - 24 GB SSD & 1TB HDD
  2. Intel Graphics 4th Gen & NVIDIA GeForce GT 750M
  3. Dual Boot Windows 10 & Ubuntu 16.04 - Uses GRUB version 2 boot loader.
  4. 16 GB Sandisk USB (Parition Type: HPFS/NTFS, Contents: NTFS)

Once I backed up everything I wanted to keep on my External HDD I started the Windows 10 Reset. It perfectly went through the preparing for reset stage. On reboot into the installation phase I first saw a black screen with a Lenovo logo and the Windows spinner below it. I let this run for a while before force resetting. I did this a couple times and got to the Installing Windows part - after a while it reached 10% and I left it on for 8 hours over night. When I woke up it was still 10% and decided to force reboot again. I keep getting stuck at the Lenovo-Spinner-Black-Screen for a few seconds which eventually the Lenovo logo disappears - Spinner-Black-Screen. Force rebooting several times with this happening eventually this led to a Lenovo-Spinner-Black screen that performed a chkdsk "Scanning and repairing drive (C:): " that proceeded to work and got stuck at 100% for over an hour and I force rebooted again. On reboot now I started to get an error window in the Spinner-Black screen

The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click "OK" to restart the computer, and then restart the installation.

I hit OK and it restarted only to get the error again on the same screen. An error reboot loop. After some searching online instead of hitting OK I did Shift+F10 and opened regedit in CMD. I set [HKEY_LOCAL_MACHINE\SYSTEM\Setup\Status\ChildCompletion] for value setup.exe from 1 to 3. This worked and got me passed the error and to the Windows-Install screen again. Except now it shows for like 2 seconds, is at 64 %, and proceeds to reboot itself without warning. Another reboot loop.

At this point I go into Ubuntu, download the Windows 10 64 bit ISO, try to set my 16 GB drive as a bootable USB so that I can fresh install. Rufus doesn't work with Wine so I have to use UnetBootin - I believe it worked just fine. However, I have no idea how to boot a USB from GRUB.

If a fresh install through USB seems to be the only option left, how can I do this through GRUB? How do I know it is installing to the correct location? Is there any way to proceed or even restart the Windows Reset Install or has it gone completely awry?

3
  • I recommend you do a reinstall. The Reset feature is by no means a factory reset! Because of the way Windows is installed (no read-only “ROM”), a simple factory reset is not possible.
    – Daniel B
    Jun 17 '17 at 17:27
  • How would I go about that in my situation? I made a bootable USB with the Windows 10 iso and UNetbootin. I can't figure out how to use this using GRUB version 2.02. Jun 17 '17 at 17:32
  • @DanielB I have no idea how to go about this. I went into BIOS from the GRUB loader and moved the Windows Boot Loader to the top so maybe it would read the usb but now I can no longer get into BIOS/GRUB and its permanently in the boot loop I was last at. Jun 17 '17 at 17:56
1

I ended up having to use another computer, download the Windows Media Creation Tool to make the USB drive correctly bootable. To get into the boot options I had to spam F12 extremely fast during the 64% Installer boot loop. I was then able to format and reinstall Windows 10 correctly.

1
  • Great to hear you solved it. The official Media Creation Tool would’ve been my recommendation too. For UEFI, you also format the USB drive with FAT32 and just copy the entire contents of the Windows ISO (not the ISO file itself) over. It would then automatically be bootable.
    – Daniel B
    Jun 17 '17 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.