2

This happens from time to time: I run a simple taskkill command (as administrator) like this:

taskkill /im sidebar.exe /f

But get the following:

ERROR: The process "sidebar.exe" not found.

Also tried without ".exe". I see the process in Task Manager:

enter image description here

Killing the process from Task Manager works.

I suspect it happens when the process appears stuck (because that's when I kill it), but it's still strange and inconsistent.

I run Windows 7 Professional SP1 64bit.

  • Try the command as this taskkill /F /IM sidebar.exe /T – Biswapriyo Jun 18 '17 at 15:09
  • Gene - What's up? Did you look over any of the below answers to see if you found either helpful in resolving your problem? – Pimp Juice IT Sep 1 '17 at 1:56
  • It's a rare problem I can't really recreate, I just wait for it to happen. Will update. – Eugene Marin Sep 1 '17 at 16:33
  • The hotfix listed in my answer may actually help ensure the problem does not ever occur proactively. Let me know if this is something you've already applied or not—wondering if you've put anything to use as such really I suppose. Shoot me a quick note on that topic when you see this. – Pimp Juice IT Sep 14 '17 at 2:26
0

I'd use tasklist to get the PID of sidebar and taskkill /PID

> tasklist |find /i "sidebar"
sidebar.exe                  17252 Console                    1       209.680 K

> for /f "tokens=2" %A in ('tasklist ^|find /i "sidebar"') Do @Echo PID=%A
PID=17252

> for /f "tokens=2" %A in ('tasklist ^|find /i "sidebar"') Do @Taskkill /PID %A
0

You cannot stop a process by using the Taskkill.exe utility in Windows

Hotfix Download Available

Symptoms

Consider the following scenario:

  • You have a computer that is running Windows 8, Windows Server 2012, Windows 7, Windows Server 2008 R2, Windows Vista, or Windows Server 2008.

  • The computer is operating under a heavy load.

  • You try to run the Taskkill.exe utility to stop a process. For example, you run the following command to stop a process that has the process ID "128":

    Taskkill.exe /PID 128

In this scenario, the process does not stop. Additionally, you receive an error message that resembles the following:

ERROR: The process "128" not found.


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.


Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows Vista Service Pack 2 (SP2)

  • Windows Server 2008 Service Pack 2 (SP2)

  • Windows 7 Service Pack 1 (SP1)

  • Windows Server 2008 R2 Service Pack 1 (SP1)

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.