12

On my logitech keyboard the Insert key has been replaced by a doubly big delete button.

I don't mind, because I never use insert mode.

However, very occasionally I end up in insert mode. Of course, when this happens, I don't have an Insert key to get me back out. So I need a reboot

How can this happen?

Is there another shortcut that gets me into 'insert' mode?

  • If this is in Microsoft Office, then double-click the INS/OVR indicator in the status bar. – Arjan Jul 24 '09 at 13:54
  • 3
    Your keyboard doesn't have the insert key on top? I mean, like this one: tech2.in.com/media/images/2009/Jan/… – Jorge Alves Jul 24 '09 at 14:52
  • 5
    they deserve a beating for modifying keyboards like this! – Axarydax Sep 17 '10 at 7:52
29

Remove num-lock and press 0     on the numpad.

| improve this answer | |
  • Note: The num-lock key disappeared from your post. – Huppie Jul 24 '09 at 14:55
  • 5
    @Huppie: I think it's funny the way it is. I'm envisioning someone trying to pop the keycap off and pressing it while it's in the palm of their hand. Hey, it's Friday and I need some amusement, what can I say? – Paused until further notice. Jul 24 '09 at 15:56
  • 1
    @Huppie: Thanks. didn't notice that. Must have deleted it by mistake when editing it. @Dennis: That made me lol :) – anand.trex Jul 24 '09 at 16:08
6

I just read somewhere that, for example on the Logitech LX-501 keyboard, the Insert is on one of the round blue buttons (next to the function keys). On some Microsoft keyboards one needs to hold down some Fn-key and press PrtScr.

So: are you sure there's no Insert key on your keyboard?

| improve this answer | |
5

trex279's answer is probably the best one you're going to find but I thought I'd throw out an alternative:

Open the On-Screen Keyboard (on WinXP: Start > All Programs > Accessories > Accesibility > On-Screen Keyboard) and click the ins key.

| improve this answer | |
4

Press Shift + 0 on the number pad to go into Insert mode.

On a laptop you may have to use Fn to get to 0 on the num pad.

E.g. on my Dell Latitude I had to press Shift + Fn + M to turn off overtype mode.

| improve this answer | |
1

My answer is very specific to one particular situation. It will not necessarily work in other situations. I have a Logitech k750-mac solar wireless keyboard. I am running on a MacBook Pro accessing a Windows 10 desktop remotely. In this situation, I use the Shift + number-pad-0 key. But it only works with some software! Furthermore, I suspect the answer to this question will be more or less a table of situations with solutions specific to those situations, rather than a general solution.

| improve this answer | |
  • This worked for me. In order to use shift+insert I had press BOTH shift keys and the number-pad-0. – eltiare Aug 22 '18 at 19:35
1

On a small laptop, like the new HP G5, you have to activate the NumLock to access the numbers pad, then use shift + 0. It is not written, but it works to activate and deactivate this stupid feature.

| improve this answer | |
0

On Logitech K811, hold fn while clicking the delete key to get insert.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.