2

I recently asked this question in the Graphic Design community to have it marked as off-topic and recommend it's placement here.

Background

Being a freshman at college, and learning that I could get Adobe Creative Cloud for $20 a month, the opportunity was not skipped. With previous knowledge in Photoshop and Illustrator this was my perfect chance to get into graphic design not only as a hobby, but for the programs I write. After "struggling" with the trackpad on my laptop, I thought it would be best to buy an Intuos Tablet. So.. I did. I came home unboxed it, installed the drivers, and restarted. You know that normal pesky stuff. I turned on my laptop and the tablet works perfectly around that system as in controlling my mouse and whatnot. I launch Photoshop CC and this is what leads into the problem section...

Problem

Photoshop CC

Upon launching Photoshop CC, creating a document, and making a background layer; I moved the stylus over to select my brush tool and began to draw on the canvas. I pressed the stylus down and nothing occurred. Thinking it might be the brush tool, I proceeded to erase the white background and nothing still. Upon continuously testing the other tools I can say for certainty that they do not work.

Illustrator CC

Thinking that this issue might carry over into Illustrator CC I wanted to test it. Upon launching, and setting up the artboard and what not, I selected my brush tool. To my surprise it actually drew, but it does not actively draw on the canvas like it will with my touchpad.

Troubleshooting

I played with both the tablet/stylus settings within System Preferences trying different things, but the problem was not solved! Thinking that it may be a Photoshop CC or Illustrator CC settings problem I searched and found nothing.

Question

Upon all of my relentless google searching and trying I still can not get this to work inside of the programs mentioned. Are there any settings that I may have overlooked on making this thing work or will it simply not work?

System Information

Laptop

  • Make: Apple
  • OS: MacOS 10.13 High Sierra Beta
  • Model: 2016 (2 Thunderbolt 3 Ports)

Photoshop CC

  • Version: 2017.1.1 (20170425.r.252 x64)

Illustrator CC

  • Version: 2017.1.0 (21.1.0 Release)

Wacom Driver

  • Version: 6.3.22-3

Update 1

Upon installing the drivers on my Girlfriend's windows 10 based laptop, and testing in Photoshop CC (Same Version) it works perfectly! If this helps reduce some scenarios.

Update 2

Through extensive research in Reddit and The Adobe Support Community, I came across something interesting! This same problem seemed to happen in earlier versions of OS updates while the drivers for Wacom were behind. So to put this to the test, I installed macOS Sierra on a portable hdd along Photoshop CC and the drivers. Come to find out it works perfectly as it should! I will update this question with an answer as to how it was "fixed".

Update 3

The answer was added, but I can not accept it as the answer within 15 hours of posting it. Anyone viewing this question from now (06/21/2017 16:48 -6:00 CDT) until 06/22/2017 07:48 -6:00 CDT please refer to the answer from the OP as to how the problem was resolved!

0

The problem that is being experienced seems to be an incompatible driver issue. The release notes provided by Wacom for the Mac 6.3.22-3 driver state the compatible operating systems are the following:

  • macOS 10.12 (Sierra)
  • Mac OS X 10.11 (El Capitan)
  • Mac OS X 10.10 (Yosemite)

But the current operating system being ran is macOS 10.13 (High Sierra) Developer Beta. Upon doing some thorough research, I found similar problems to this happening, but with an earlier version of the operating system. In example, Someone updated their Mac to 10.12.1, and Wacom did not have an updated driver at the time.

Taking all of that into note, I started to install macOS 10.12.5 (Sierra) onto an external hard drive using this guide from Apple. In theory since the driver is updated to support macOS 10.12 this should work. After the install and setup completed, I installed the latest Wacom driver from here, and Adobe Photoshop CC (2017) from Adobe's product website. Upon restarting and testing in Photoshop CC, everything worked perfectly. I was able to utilize all the tools in Photoshop CC with no problem. Upon testing in Illustrator CC I was also able to actively see my artboard update with the lines I was drawing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.