6

I'm using Dropbox on an Arch Linux System. Everything worked fine for months now, until today. When running Dropbox from command line, it prints the error message:

Unable to monitor entire Dropbox folder hierarchy. Please run "echo fs.inotify.max_user_watches=100000 | sudo tee -a /etc/sysctl.conf; sudo sysctl -p" and restart Dropbox to fix the problem.

I don't like running terminal commands blindly without thinking about it, especially when running as sudo. So I'd really like to understand why Dropbox needs that fix, especially after running fine for months.

1
  • 4
    It may be because the Dropbox folders have got larger (number of files), or that other apps are using inotify. You can check your current value with sysctl fs.inotify.max_user_watches. Anyway the command recommended seems safe and not a high value (I have 524288). This is informative: askubuntu.com/questions/154255/…
    – Joe P
    Jun 21, 2017 at 0:24

1 Answer 1

3

I had this exact issue on Fedora 30. I tried the suggested command but it didn't work. Saw this answer and tried increasing inotify to 500000 instead of 100000 suggested. This worked for me.

sudo echo fs.inotify.max_user_watches=500000 | sudo tee -a /etc/sysctl.conf; sudo sysctl -p

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .