I suddenly can't access any of the NAS network share folders. We have an old WD My Book World II. Tried with several PCs.

net use q: \\My.Nas.Ip.Here\Public

gives me: Systemerror 53

Any ideas? I can access the web configuration page of the NAS with no problem.

Just noticed that on the Storage Tab of the NAS web panel I the following which I think is new:

mdadm: cannot open /dev/md2: No such file or directory mdadm: cannot open /dev/md2: No such file or directory

  • Did Microsoft just kill SMB1?.... – djsmiley2kStaysInside Jun 21 '17 at 9:41
  • I thought about that too. How can I test that? I also have a mac to test stuff. – CodingYourLife Jun 21 '17 at 9:42
  • Not sure to be quite honest. Does it work on the Mac? Did it previously work on the mac? – djsmiley2kStaysInside Jun 21 '17 at 9:44
  • Have you tried to reboot the NAS? It hasn't been the first time when a coincidence has thrown me completely off track. It could simply be the NAS. – LPChip Jun 21 '17 at 9:45
  • 1
    Systemerror 67: Network name not found. Can you still access the nas by ip to go into the web interface? – LPChip Jun 21 '17 at 9:46

As I understand, Disabling SMB V1 seems to be a common occurrence at the moment.

Perhaps if you jump into REGEDIT.MSC and check the following:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters Registry entry: SMB1

By default this used to be set to 1, which is enabled. Although many machines I've seen recently are now set to 0, which is disabled, for some reason!

Is yours set to 0? If so, I'd change the Value to 1 and try again.

  • I don't have such an entry under the Parameters folder in regedit so I guess it's at default setting. – CodingYourLife Jun 21 '17 at 15:19
  • What version of Windows are you running? So far I haven't come across a machine with this missing! – LordMarvolo Jun 22 '17 at 9:21
  • It turned out that the root cause of my problem was that the RAID was messed up and not a problem with the OS as I thought first. Thanks anyway for your answer I'm sure it helps others having a similar problem – CodingYourLife Jun 22 '17 at 14:39

At first I suspected the latest Windows updates but it was clearly a problem with the NAS itself. Something with the Raid (wich was set to Mirror mode) was messed up for some reason after years without problems. The web interface showed Failure under Storage>Volumes&RAID. I couldn't see my files with SSH and I tried several things and Tools. I was able to restore all the data via an USB2Sata Adapter using the software Raise Data Recovery from SysDev Laboratories for about 35€ (with extra license for this linux file system). I did a drive wipe and prepaired the drives for first use by following this video

Thanks for all the answers that helped me find out the root problem. Just lost a lot of time copying stuff back and forth but luckily no data loss so I can't complain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.